NetBeans IDE 5.0を使って、Javaプログラミングをしています。

昨日まで普通に使えていたのですが、今日になって起動してみると、以下のエラーが出てコンパイルや実行ができなくなってしまいました。設定は何もいじっていません。

エラー。Ant が正しく設定されていないため実行できません。
java.lang.NullPointerException
at org.apache.tools.ant.module.bridge.AntBridge.createCustomDefs(AntBridge.java:468)
at org.apache.tools.ant.module.bridge.AntBridge.createStuff(AntBridge.java:290)
at org.apache.tools.ant.module.bridge.AntBridge.getStuff(AntBridge.java:242)
at org.apache.tools.ant.module.bridge.AntBridge.getInterface(AntBridge.java:231)
at org.apache.tools.ant.module.run.TargetExecutor.run(TargetExecutor.java:287)
at org.netbeans.core.execution.RunClassThread.run(RunClassThread.java:125)

どのようにしたら直りますでしょうか。

回答の条件
  • 1人2回まで
  • 登録:2008/12/01 15:31:29
  • 終了:2008/12/02 01:04:37

ベストアンサー

id:pahoo No.1

pahoo回答回数5960ベストアンサー獲得回数6332008/12/01 19:02:41

ポイント60pt

JDKをアップグレードしたか、Microsoft VM が有効になっていませんか?

NetBeans IDE 5.0 が動作保証しているのは JDK 5.0 だけです。

「コントロールパネル」→「プログラムの追加と削除」から、インストールされている JDK を確認してみてください。

id:Gakuen

お世話になりっぱなしですね。

もう何回答えていただいたことか。

いつもありがとうございます。

2008/12/02 00:44:32
  • id:pahoo
    Gakuen > お世話になりっぱなしですね。

    どうぞ気になさらずに。
    NetBeansは昔取った杵柄(苦笑)ですが、お役に立てれば何よりです。

この質問への反応(ブックマークコメント)

「あの人に答えてほしい」「この質問はあの人が答えられそう」というときに、回答リクエストを送ってみてましょう。

これ以上回答リクエストを送信することはできません。制限について

絞り込み :
はてなココの「ともだち」を表示します。
回答リクエストを送信したユーザーはいません