PHPで書かれたプログラムで、$_SERVER変数のPATH_TRANSLATEDを利用しているものがあります。

このたびサーバーを移転してApacheのバージョンが1.3→2.0に変わりました。
Apache2.0からPATH_TRANSLATEDが設定されなくなったのですが、なんとかPATH_TRANSLATEDが設定
されるようにしたいのですが、何か方法はありますか。
諸事情によりPHPのスクリプトを書き直すのは避けたいです。

回答の条件
  • 1人2回まで
  • 登録:2009/02/06 13:10:32
  • 終了:2009/02/13 13:15:02

回答(1件)

id:pahoo No.1

pahoo回答回数5960ベストアンサー獲得回数6332009/02/06 13:39:41

ポイント60pt

Apache の SetEnv ディレクティブを利用し、httpd.conf または .htaccess に PATH_TRANSLATED の値を記述してはいかがでしょう。

id:orihomot

ありがとうございます。やってみます!!

2009/02/06 14:05:58

コメントはまだありません

この質問への反応(ブックマークコメント)

「あの人に答えてほしい」「この質問はあの人が答えられそう」というときに、回答リクエストを送ってみてましょう。

これ以上回答リクエストを送信することはできません。制限について

絞り込み :
はてなココの「ともだち」を表示します。
回答リクエストを送信したユーザーはいません