perl の Compress::Zlib で以下のようなエラーが出てしまいます。


$ perl -MCompress::Zlib
is only avaliable with the XS version at /usr/lib/perl5/site_perl/5.8.8/Compress/Zlib.pm line 9
BEGIN failed--compilation aborted at /usr/lib/perl5/site_perl/5.8.8/Compress/Zlib.pm line 9.
Compilation failed in require.
BEGIN failed--compilation aborted.

cpan> install Compress::Zlib すると、テストでエラーが多発します。

ネット上で調べてみたところ、Scalar::Util を最新化すると直るみたいなことが書いてあったのですが、cpan コマンドで force install Scalar::Util したり、手動で .tar.gz から展開してインストールしても、Scalar::Util が最新化しないように見えます。

$ perl -MScalar::Util -le 'print $Scalar::Util::VERSION'
1.18
(最新版は 1.19 のはず)

OS は Fedora Core 5, perl は 5.8.8 です。

どなたか原因がおわかりになる方、教えていただければと思います。

回答の条件
  • 1人50回まで
  • 登録:2009/04/17 22:56:06
  • 終了:2009/04/24 23:00:03

回答(0件)

回答はまだありません

コメントはまだありません

この質問への反応(ブックマークコメント)

「あの人に答えてほしい」「この質問はあの人が答えられそう」というときに、回答リクエストを送ってみてましょう。

これ以上回答リクエストを送信することはできません。制限について

絞り込み :
はてなココの「ともだち」を表示します。
回答リクエストを送信したユーザーはいません