MAC/G4のOS.10.3.9やMacクラシックの【Safari】環境を、最も最安に構築できる方法はなんですか?


・ウィンドウズ上に仮想シミュレータ
・オークションで買ってSafariインストール

価格と方法を教えてください。
windows版のSafari1.3やMacOSX10.5のSafariでは再現できないバグを確認するためです。

回答の条件
  • 1人2回まで
  • 登録:2009/04/20 11:13:45
  • 終了:2009/04/27 11:15:02

回答(2件)

id:kotobatojp No.1

kotobato回答回数87ベストアンサー獲得回数192009/04/20 12:11:56

ポイント35pt

ClassicのSafari → SafariはMac OS Xが動作環境なので対象外

Mac OS X 10.3.9のSafari → 10.3.9のOSディスクとマシン


ということで、後者で説明しますが、結論は、

 旧モデルをOSセットで入手する

のが一番確実で、コストパフォーマンスがいいと思います。

(Windowsでエミュレーターがあるかどうか、機能も含めて知りませんが、所詮エミュレーターはエミュレーターですし)


残念ながら、OSもマシンも、販売店で新品は非常に入手しにくいと思います。

Apple Storeの整備済商品でも10.5メインですから。

そこで、以下のようなポイントを重点に、環境を整備すればいいのではないでしょうか。

(実際、10.3→10.4の移行期間に、仕事で似たようなオーダーを受けていました)

後は、VNCなどで接続すれば、扱いも楽かもしれません。


  • 場所を取らないPowerBookやiBook、Mac miniなど、当時のモデル
  • 必ずOSのディスクがセットになっている
  • 程度の良いマシンを、中古屋かオークションでゲット(価格はそれぞれ)
  • ディスクを完全にメンテナンス(必要であれば換装)してからアップデート
  • 余分なツールを入れず、極力ノーマル
  • Safariのテスト以外に利用しない
  • id:yo-net No.2

    yo-net回答回数265ベストアンサー獲得回数212009/04/20 16:39:36

    ポイント35pt

    1の方に追加で、

    10.3時代のMacOSはPowerMacしか使えないので、

    もしMacProしかお持ちで無い場合は、PowerPCのCPUを搭載した、

    Macは必ず購入しないと動きません。

    IntelのCPUを搭載したMacProは10.4からになります。

    safariのv1を使いたい場合は10.3をインストールするしか無いのかもれませんね。

    safariのv2は10.3では動きませんので、古いsafariはどのバージョンを使いたいかによって

    MacOSの買うバージョンに気をつけてくださいませ。

    金額ですがG5でもシングルCPU程度であれば5万以下で購入できると思います。

    ヤフオクとかソフマップあたりが良いと思います。

    OSだけなら1万円以下で購入できると思います(中古、まれに未開封の新品)

    http://ja.wikipedia.org/wiki/Safari

    コメントはまだありません

    この質問への反応(ブックマークコメント)

    「あの人に答えてほしい」「この質問はあの人が答えられそう」というときに、回答リクエストを送ってみてましょう。

    これ以上回答リクエストを送信することはできません。制限について

    絞り込み :
    はてなココの「ともだち」を表示します。
    回答リクエストを送信したユーザーはいません