Rails初心者です。

gemでgetttextをインストールし「environment.rb」をを書き換えた後サーバーを起動すると以下のエラー文がでました。
何が問題でどう対処すればよいのでしょうか?

/Library/Ruby/Site/1.8/rubygems/custom_require.rb:31:in `gem_original_require': no such file to load -- gettext/rails (MissingSourceFile)
from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:31:in `require'
from /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/gems/1.8/gems/activesupport-1.4.4/lib/active_support/dependencies.rb:495:in `require'
from /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/gems/1.8/gems/activesupport-1.4.4/lib/active_support/dependencies.rb:342:in `new_constants_in'
from /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/gems/1.8/gems/activesupport-1.4.4/lib/active_support/dependencies.rb:495:in `require'
from /Users/***/Documents/workspace/memopad/config/environment.rb:62
from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:31:in `gem_original_require'
from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:31:in `require'
from /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/gems/1.8/gems/activesupport-1.4.4/lib/active_support/dependencies.rb:495:in `require'
(残り文字数制限のため不掲載)

ruby 1.8.6
Rails 2.3.5
gettext 2.1.5

回答の条件
  • 1人2回まで
  • 登録:2009/12/07 09:32:34
  • 終了:2009/12/13 06:35:11

ベストアンサー

id:lunlumo No.3

lunlumo回答回数107ベストアンサー獲得回数142009/12/13 03:47:00

ポイント50pt

 同じ現象に遭った事は無いのですが,検索した所環境変数GEM_HOMEを設定してなおったとの情報が引っ掛かりました。

http://www.gesource.jp/weblog/?p=427

 因に,2.2から標準で国際化ライブラリが含まれているので,特に理由がないのであればそちらを使われた方が良いのではないかと。

http://guides.rubyonrails.org/i18n.html

id:o8o

指定のバージョンに合わせてたり環境変数GEM_HOMEを設定してみましたが駄目でした。

標準で国際化ライブラリを使用してみようと思います。

ありがとうございました。

2009/12/13 06:34:28

その他の回答(2件)

id:snow_leopard No.1

snow_leopard回答回数294ベストアンサー獲得回数222009/12/08 02:43:31

ポイント20pt

railsのバージョンによって動作しないこともあるとか。

http://www.yotabanana.com/hiki/ja/ruby-gettext-howto-ror.html

id:azumi1975 No.2

azumi1975回答回数337ベストアンサー獲得回数162009/12/08 06:11:29

ポイント10pt

environment.rbの設定を見直してください

id:lunlumo No.3

lunlumo回答回数107ベストアンサー獲得回数142009/12/13 03:47:00ここでベストアンサー

ポイント50pt

 同じ現象に遭った事は無いのですが,検索した所環境変数GEM_HOMEを設定してなおったとの情報が引っ掛かりました。

http://www.gesource.jp/weblog/?p=427

 因に,2.2から標準で国際化ライブラリが含まれているので,特に理由がないのであればそちらを使われた方が良いのではないかと。

http://guides.rubyonrails.org/i18n.html

id:o8o

指定のバージョンに合わせてたり環境変数GEM_HOMEを設定してみましたが駄目でした。

標準で国際化ライブラリを使用してみようと思います。

ありがとうございました。

2009/12/13 06:34:28

コメントはまだありません

この質問への反応(ブックマークコメント)

「あの人に答えてほしい」「この質問はあの人が答えられそう」というときに、回答リクエストを送ってみてましょう。

これ以上回答リクエストを送信することはできません。制限について

絞り込み :
はてなココの「ともだち」を表示します。
回答リクエストを送信したユーザーはいません