CentOS5.4でstoneとopensslを使い外部から自宅サーバへ(windowsマシンからteratermで)接続したいと考えていますが、その設定方法を教えてください。自宅の回線終端装置のポート設定はできています。stoneとopensslのインストールで躓いています...

回答の条件
  • URL必須
  • 1人10回まで
  • 13歳以上
  • 登録:2010/04/27 02:05:06
  • 終了:2010/05/04 02:10:02

回答(3件)

id:JULY No.2

JULY回答回数966ベストアンサー獲得回数2472010/04/27 13:09:57

ポイント40pt

m-FILTERをパケットリピーターを使いPOP3s(POP over SSL)に対応させる。 | 決まらないタイトル。決まるスケジュール。

上記ページに導入手順が書かれています。

stone の rpm パッケージがどこかにあればそれでも良いのですが、CentOS の標準リポジトリ、RPMForge、EPEL といった有名どころの別のリポジトリでも見つかりませんでした。

なので、

  1. ソースからコンパイルできる環境を用意する(gcc、make のインストール)
  2. openssl を使ったソフトをコンパイルするためのパッケージをインストール(openssl-devel のインストール)
  3. stone のコンパイル

という流れになっています。

id:ikazuo

手順通りに実行しました。


1. 必要なアプリをインストール

# yum install gcc
# yum install make
# yum install openssl-devel

2. stoneを解凍・インストール

# wget http://www.gcd.org/sengoku/stone/stone-2.3e.tar.gz
# tar zxvf stone-2.3e.tar.gz
# cd stone*
# make linux-ssl
# cp stone /usr/local/bin

3. stoneの起動

# stone -D localhost:22 443/ssl

stoneのプロセスが起動していないようです。

[root@centos src]# ps -ef | grep stone
root      2934  2871  0 16:09 pts/0    00:00:00 grep stone
[root@centos src]# netstat -an | grep 443
[root@centos src]#

rpmは以下のとおりです。

[root@centos ssl]# rpm -qa | grep ssl
openssl-devel-0.9.8e-12.el5_4.6
openssl-0.9.8e-12.el5_4.6
[root@centos ssl]#


make stone.pemが必要でしょうか。

2010/04/27 16:24:40
id:hanako393 No.3

hanako393回答回数1142ベストアンサー獲得回数872010/04/27 16:36:08

ポイント40pt

>make stone.pemが必要でしょうか。

必要です。

http://q.hatena.ne.jp/answer

id:ikazuo

make stone.pemを実行しても何も起こらず、

Makefileがあるcertsディレクトリがなかったため一度sslをアンインストールしようと以下を実行しました。

[root@centos ~]# yum -y remove openssl-devel
Complete!
[root@centos ~]# yum -y remove openssl
Another app is currently holding the yum lock; waiting for it to exit...
  The other application is: yum
    Memory :  26 M RSS ( 57 MB VSZ)
    Started: Tue Apr 27 16:53:44 2010 - 00:50 ago
    State  : Sleeping, pid: 8513


Exiting on user cancel.
[root@centos ~]#

[root@centos ~]# rpm -e --nodeps openssl-0.9.8e-12.el5_4.6
[root@centos ~]# rpm -aq | grep ssl
[root@centos ~]#

openssl-devのインストールができなくなりました...

[root@centos src]# yum install openssl-devel
Traceback (most recent call last):
  File "/usr/bin/yum", line 4, in ?
    import yum
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 50, in ?
    import config
  File "/usr/lib/python2.4/site-packages/yum/config.py", line 27, in ?
    from parser import ConfigPreProcessor
  File "/usr/lib/python2.4/site-packages/yum/parser.py", line 3, in ?
    import urlgrabber
  File "/usr/lib/python2.4/site-packages/urlgrabber/__init__.py", line 53, in ?
    from grabber import urlgrab, urlopen, urlread
  File "/usr/lib/python2.4/site-packages/urlgrabber/grabber.py", line 412, in ?
    import keepalive
  File "/usr/lib/python2.4/site-packages/urlgrabber/keepalive.py", line 339, in ?
    class HTTPSHandler(KeepAliveHandler, urllib2.HTTPSHandler):
AttributeError: 'module' object has no attribute 'HTTPSHandler'
2010/04/27 17:07:09

コメントはまだありません

この質問への反応(ブックマークコメント)

「あの人に答えてほしい」「この質問はあの人が答えられそう」というときに、回答リクエストを送ってみてましょう。

これ以上回答リクエストを送信することはできません。制限について

絞り込み :
はてなココの「ともだち」を表示します。
回答リクエストを送信したユーザーはいません