普段phpを使用しているプログラマーです。これからRailsの勉強をしたいと考えておりますが、Railsのバージョン(1.0系or2.0系)を何から始めるのがメジャーなのかと困っております。

普段Railsで開発されている方に回答頂けたら嬉しいです。

回答の条件
  • 1人1回まで
  • 13歳以上
  • 登録:2010/08/02 07:30:06
  • 終了:2010/08/09 07:35:03

ベストアンサー

id:karuishi No.2

ニャンざぶろう回答回数764ベストアンサー獲得回数1282010/08/02 21:38:31

ポイント23pt

新しく学習するなら、やっぱり最新版の2.3.8でしょう。

 

Ruby on Railの本家

http://rubyonrails.org/ の

Get Started のバージョンも2.3.8ですしStableの位置づけですよ~。

その他の回答(3件)

id:yamaneroom No.1

yamaneroom回答回数1040ベストアンサー獲得回数612010/08/02 09:27:19

ポイント23pt

Ruby on Railsを使うならバージョン2.2以上を使おう。

id:camelmasa

回答有難う御座います!

なんか熱いコメントで。嬉しいです!

2010/08/02 09:33:20
id:karuishi No.2

ニャンざぶろう回答回数764ベストアンサー獲得回数1282010/08/02 21:38:31ここでベストアンサー

ポイント23pt

新しく学習するなら、やっぱり最新版の2.3.8でしょう。

 

Ruby on Railの本家

http://rubyonrails.org/ の

Get Started のバージョンも2.3.8ですしStableの位置づけですよ~。

id:cuspos No.3

cuspos回答回数49ベストアンサー獲得回数102010/08/03 11:11:43

ポイント22pt

2.3.8使ってください。

1系とでは内部的にも書き方的にも、いろいろ作法が異なります。

最近仕事の合間にプログラム初心者に教えながらWEBアプリ実装しましたが、初心者でも1ヶ月かからずざっくりとした実装ができるようになります。頑張ってくださいね。

id:basasitarou No.4

basasitarou回答回数5ベストアンサー獲得回数02010/08/04 16:37:11

ポイント22pt

もうすぐ3も出ることですし、1のことはほっといて良いと思います。

3が出ることに備え、2.3系の安定版を勉強しておくことをお勧めします。

  • id:windofjuly
    うぃんど 2010/08/02 08:45:43
    rubyはあまり触る機会がないのでコメントにしておきます
     
    【1】仕事先にRails1.x系での開発を行っていた実績があるならば
    1.xと2.xの両方を使えないことにはメンテナンスやアップデートに戸惑うことでしょう
     
    【2】 仕事先もはじめてRailsに取り掛かるということであるならば
    営業の方法によって変わってきますね
    既存Rails1.x系の一部手直しも引き受けるならば当然ながら1.x系と2.x系の両方が必要でしょう
    全面的リプレースで営業をかけるならば2.x系で精進したほうがよいでしょう
     
    【3】私があなたの立場ならば
    最低2年は経っているであろう他者が作ったものを改良するよりも、新たに作るほうが断然楽だったりしますので、無理の無いという点で2.x系で始めると思います
  • id:camelmasa
    id:windofjulyさん

    コメント有難う御座います!
    私の場合【3】に該当致しますので、やはり2.x系から勉強した方が良いのかなと感じました。
  • id:windofjuly
    うぃんど 2010/08/02 09:41:17
    >熱いコメント
    理由も示さず大きな文字にしておくだけで質問者は騙されるのだなと笑ってしまいました
    回答履歴をみればいいかげんさがわかると思いますよ
    どうして2.3ではなく2.2なのかとか聞いてみてもいいかもしれないですが、どうせまた単語を抜粋して適当にググってくるだけだからやるだけ無駄かな
  • id:camelmasa
    id:windofjulyさん

    コメント有難う御座います。

    私の方でも2.x系の最新バージョンが2.3.8なのが確認できましたので、2.2系と2.3系ではどの様に違うのか等を少し調べまして、どれを使用するか考えたいと思っております。
  • id:yamaneroom
    yamaneroom 2010/08/02 11:47:24
    No.1で回答した者だが、「バージョン2.2以上」と明記している。
    バージョン2.3ではいけないなどとは書いていない。
    コメントで批判する前に、きちんと回答文を読んでいただきたい。
  • id:windofjuly
    うぃんど 2010/08/02 12:23:55
    >バージョン2.3ではいけないなどとは書いていない。
    はぐらかそうとしてませんか? 疑問点は「どうして2.2以上なのか?」ですよ
  • id:karuishi
    多分、このあたりのコピペだと思うなあ。
      
    「Ruby on Railsを使うならバージョン2.2以上を使おう」
    http://www.gesource.jp/weblog/?p=733
     
    一字一句同じ、質問者さんをバカにしすぎ。

この質問への反応(ブックマークコメント)

「あの人に答えてほしい」「この質問はあの人が答えられそう」というときに、回答リクエストを送ってみてましょう。

これ以上回答リクエストを送信することはできません。制限について

絞り込み :
はてなココの「ともだち」を表示します。
回答リクエストを送信したユーザーはいません