iPhoneについて、現在家で2台のiPhoneがあります。

1台(黒色)は正常にWiFiに繋がるのですが、もう1台(白色)は「パスワードが正しくありません」と出て繋がりません。

ルーターは"I-O DATA WN-G54/R3"です。
機種はいずれも3GS、OSも両方ともiOS4.1です。
同時に購入したので時期的な機種の違いはないと思います。

ルーターのパスワードですが、2台に同じものをメールで送り、どちらもそれをコピペして入力しましたが、
やはり片方のiPhone(白色)だけ繋がりません。
ルーターのSSIDは表示されるので、LANは認識されているようです。
どこかのサイトで「電源を落として再起動すれば繋がる」というのがありましたが、ダメなようです。

3G回線ではiTunesの曲や20MBを超えるアプリなどがダウンロードできず、パケットもかさんで大変困っています。
どうにか解決方法はありませんでしょうか?

回答の条件
  • 1人3回まで
  • 13歳以上
  • 登録:2010/09/09 22:44:43
  • 終了:2010/09/13 23:33:09

回答(5件)

id:tasklight No.1

tasklight回答回数323ベストアンサー獲得回数402010/09/09 23:57:05

ポイント80pt

WN-G54/R3のファームウェアを最新の1.06にアップデートしてみてください。

id:otaxa

以前に同機種のルーターでファームウェアをアップデートした際、

ルーターが起動すらしなくなり、サポートに聞いたら「自己責任だからしょうがない」ということで、今のは2台目ルーターなんです。

なので、ファームウェアのアップデートは怖くてできません…

ほかのPCやゲーム機などはすべて問題なく無線で繋がっているので、ルーター側の問題には思えないのですが…

2010/09/10 06:51:53
id:simoke123 No.2

simoke123回答回数220ベストアンサー獲得回数02010/09/09 23:07:33

(はてなにより削除しました)

質問者が未読の回答一覧

 回答者回答受取ベストアンサー回答時間
1 simoke123 220 7 0 2010-09-09 23:34:41
2 simoke123 220 7 0 2010-09-10 01:43:23
  • id:seble
    高いブランド激安とかソーダとか(MPになっちゃうじゃねぇか)めちゃくちゃでんな。

    閑話休題
    wepの、、、(64bit?128bit?)パスが間違っていないとして、ルーター側にmacアドレスの制限がかかっていませんか?
    macアドレスは無線機器全てに個別のIDがあり、それによって接続を拒否したりできます。
    また、子機側でチャンネルが固定されていて同じチャンネルだと接続できません。
    (近いチャンネルも混信して遅くなるので3つ以上離す)
    ANY接続拒否機能などは入っていませんよね?
    また、ルーターのDHCPも有効になっていますよね?
    IPアドレスの自動付与という事ですが、、、

    試しに、正常側のiPhoneをとめて、異常側1台だけでは接続できませんか?
  • id:otaxa
    >sebleさん
    コメントありがとうございます。
    家電カテゴリで質問するとなぜかスパム回答が来ちゃうんですよね…

    macアドレスについてですが、ルーターにiPhoneのmacアドレスを直接許可指定してもダメでした。
    また、繋がる方のiPhoneを含め、全ての機器はDHCPで繋げてます。
    繋がらない方のiPhone側でIPアドレス等を手動設定してみてもダメでした。

    全機器のLANを切って試してみたのですが、これもダメで…
    iPhoneの故障もあり得る気がしてきました…
    (ルーターは認識してるんですが。)
  • id:ytakan
    FreeSpotとかBBモバイルポイントとか自宅以外の無線LANに繋げてみても、繋がらないようなら初期不良では?
  • id:otaxa
    >ytakanさん
    ありがとうございます。
    無線の「BB User」というポイントに試しに繋いでみたら、繋がるようです。
    他のソフトバンクのmobilepointなどはまだ試せていません。(近くにないので)

    購入してから半年ほどは問題なく繋がっていましたが、1ヶ月ほど前に突然繋がらなくなったので初期不良ではないと思います。
    OSを新しくしたら治るかもと思い、きのうiOS3.1*→4.1にしてみましたが改善されませんでした・・・
  • id:otaxa
    ちなみにルーター「WN-G54/R3」のファームウェアは最新の1.06でした。
  • id:otaxa
    いろいろやっていたら、なんとか繋がりました。
    以下のような手順です。

    ルーターのSSIDを変更し、パスワードも簡単なものに変更
    (WEPでパスワード「00000」など)

    設定アプリ→一般→リセット→ネットワーク設定をリセット(強制再起動)

    起動後、さらにハードリセット
    (ホームボタンとロックボタン同時押しで「電源オフ」のスライダが出ても押し続け、再起動後アップルマークが出るまで押し続ける)

    設定アプリ→Wi-Fi→変更したSSIDを選択

    設定した簡単なパスワードを入力(ここで認証できなければお手上げ)

    認証成功

    ルーターのSSIDとパスワードを元に戻す

    iPhoneをハードリセット(念のため)

    設定アプリ→Wi-Fi→変更後のSSIDで、パスワードを手入力し設定
    ★★★コピペではダメな場合がある!(文字コードや改行の関係?)★★★

    認証成功

この質問への反応(ブックマークコメント)

「あの人に答えてほしい」「この質問はあの人が答えられそう」というときに、回答リクエストを送ってみてましょう。

これ以上回答リクエストを送信することはできません。制限について

絞り込み :
はてなココの「ともだち」を表示します。
回答リクエストを送信したユーザーはいません