WordPressで、Twenty Ten 1.1(デフォルト設定)というテーマを使っています。

Syntax Highlighter Evolvedというプラグインをインストールしたのですが、
月別アーカイブのページではプラグインが有効になりません。

何か編集する部分があるのでしょうか?
よろしくお願いします。

回答の条件
  • 1人2回まで
  • 13歳以上
  • 登録:2010/10/29 12:26:52
  • 終了:2010/10/30 00:27:41

ベストアンサー

id:rouge_2008 No.1

rouge_2008回答回数594ベストアンサー獲得回数3512010/10/30 00:03:58

ポイント60pt

そのプラグインは、「the_content()」で表示している内容に適用されるようになっています。

次のようにテーマを編集すると、月別アーカイブやカテゴリページでも適用させる事ができます。

・「loop.php」(131行目付近・編集前)

	<?php if ( is_archive() || is_search() ) : // Only display excerpts for archives and search. ?>
			<div class="entry-summary">
				<?php  the_excerpt(); ?>
			</div><!-- .entry-summary -->


・「loop.php」(131行目付近・編集後)

	<?php if ( is_archive() || is_search() ) : // Only display excerpts for archives and search. ?>
			<div class="entry-summary">
				<?php the_content("",true); ?>
			</div><!-- .entry-summary -->

※「the_excerpt()」で表示した場合、moreより前だけが表示されますので、「続きを読む」のテキストは非表示にしています。

http://wpdocs.sourceforge.jp/%E3%83%86%E3%83%B3%E3%83%97%E3%83%A...

http://wpdocs.sourceforge.jp/%E3%83%86%E3%83%B3%E3%83%97%E3%83%A...



※分からない所がある場合は、コメント欄を開けてくださるとやり取りしやすいです。

id:is0me

解決しました!

ありがとうございます。

2010/10/30 00:26:19

コメントはまだありません

この質問への反応(ブックマークコメント)

「あの人に答えてほしい」「この質問はあの人が答えられそう」というときに、回答リクエストを送ってみてましょう。

これ以上回答リクエストを送信することはできません。制限について

絞り込み :
はてなココの「ともだち」を表示します。
回答リクエストを送信したユーザーはいません