gitに関する質問です。

MacPortsでgit-coreをインストールしようと、下記コマンドを流したのですが、コメント欄のようなエラーがでて、うまくいきませんでした。具体的な解決手順をご教授ください。よろしくお願い致します。

$sudo port install git-core +gitweb +svn

※マシンのスペック
2010年10月に発売されたmac book air(mac os xのバージョンは10.6.5)

回答の条件
  • 1人2回まで
  • 13歳以上
  • 登録:2010/12/09 16:28:37
  • 終了:2010/12/16 16:30:02

ベストアンサー

id:ktoshi No.1

ktoshi回答回数107ベストアンサー獲得回数62010/12/09 20:37:31

ポイント60pt

これやってからでどうですか?

sudo port clean curl-ca-bundle

『gitをブラウズするのに最適な「tig」をMacportsから入れてみた』

http://hisasann.com/housetect/2010/11/gittigmacports.html

id:puriketu99

ありがとうございます。

無事macportsからのインストールができました。

2010/12/09 22:31:27
  • id:puriketu99
    :!sudo port install git-core +gitweb +svn
    Portfile changed since last build; discarding previous state.
    ---> Computing dependencies for openssl
    ---> Fetching openssl
    ---> Attempting to fetch openssl-1.0.0c.tar.gz from http://distfiles.macports.org/openssl
    ---> Verifying checksum(s) for openssl
    ---> Extracting openssl
    ---> Applying patches to openssl
    ---> Configuring openssl
    ---> Building openssl
    ---> Staging openssl into destroot
    ---> Computing dependencies for openssl
    ---> Installing openssl @1.0.0c_0
    ---> Deactivating openssl @1.0.0b_0
    ---> Cleaning openssl
    ---> Activating openssl @1.0.0c_0
    ---> Cleaning openssl
    ---> Computing dependencies for git-core
    ---> Dependencies to be installed: curl curl-ca-bundle libidn p5-error p5-libwww-perl p5-compress-raw-zlib p5-crypt-ssleay p5-html-parser p5-html-tagset p5-io-compress p5-compress
    -raw-bzip2 p5-uri p5-svn-simple subversion-perlbindings apr apr-util cyrus-sasl2 neon serf subversion p5-term-readkey rsync popt
    ---> Verifying checksum(s) for curl-ca-bundle
    Error: Target org.macports.checksum returned: certdata-1.70.txt does not exist in /opt/local/var/macports/distfiles/curl
    Error: Failed to install curl-ca-bundle
    Log for curl-ca-bundle is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_net_curl-ca-bundle/main.log
    Error: The following dependencies were not installed: curl curl-ca-bundle libidn p5-error p5-libwww-perl p5-compress-raw-zlib p5-crypt-ssleay p5-html-parser p5-html-tagset p5-io-co
    mpress p5-compress-raw-bzip2 p5-uri p5-svn-simple subversion-perlbindings apr apr-util cyrus-sasl2 neon serf subversion p5-term-readkey rsync popt
    Error: Status 1 encountered during processing.
    To report a bug, see <http://guide.macports.org/#project.tickets>

この質問への反応(ブックマークコメント)

「あの人に答えてほしい」「この質問はあの人が答えられそう」というときに、回答リクエストを送ってみてましょう。

これ以上回答リクエストを送信することはできません。制限について

絞り込み :
はてなココの「ともだち」を表示します。
回答リクエストを送信したユーザーはいません