PHPDocumentorについて質問です。


MAC環境にて、PHPDocumentorにてドキュメント作成しようと思ったのですが、
htmlファイルを生成する所までは出来たのですが、テンプレートの部分で

compiled from index.tpl */ ?> compiled from header.tpl */ ?>

と表示が切れたような状態になり、完全な状態で作成出来ません。
(tplを使用している全てのhtmlファイルがそうなります)。

smartyの設定か関連部分だと思うのですが、どこをどう直せば
正常に表示ができるかが判らないでいます。

非常に困っているので、教えて頂けると幸いです。

回答の条件
  • 1人5回まで
  • 13歳以上
  • 登録:2011/01/11 14:17:57
  • 終了:2011/01/17 02:42:10

ベストアンサー

id:Galapagos No.2

Galapagos回答回数963ベストアンサー獲得回数892011/01/11 17:14:04

ポイント35pt

1で回答した者です。

PHPDocmentorをインストールする前にSmartyをインストールする必要があります。

ご確認ください。

id:dogdog555

インストールはしていて、phpDocumentor配下にある

Converter.incにて、Smarty.class.phpでインクルードしています。

念のため別のsmatryをインストールし、

該当箇所(includeしている箇所)に絶対パスで再指定、

etc/binのphp.iniファイルで対応付けがきちんとなるように対処し試してもだめです。

他の方が質問されているような文字化けについても、Converters配下のテンプレート、

iso〜を修正等も試し、修正済みです(上記トラブルとは関係ないと思っていますが)。

2011/01/11 22:41:53

その他の回答(1件)

id:Galapagos No.1

Galapagos回答回数963ベストアンサー獲得回数892011/01/11 14:42:37

ポイント35pt

Smartyはインストールされていますか?


もし未だのようでしたら、「Mac OS X に Smarty をインストールする」を参考にインストールしてください。

id:dogdog555

PHPDocmentorをインストールすると、「Converters」がある階層と同階層に「Smarty-2.6.0」が出来ています。

つまり、同時にPHPDocmentor内でこのsmartyが有効になるのではないのでしょうか?

phpdocコマンドを実行するとそこにアクセスされ、同階層の「Converters」テンプレートを参照するイメージで

いるのですが・・・

2011/01/11 14:52:56
id:Galapagos No.2

Galapagos回答回数963ベストアンサー獲得回数892011/01/11 17:14:04ここでベストアンサー

ポイント35pt

1で回答した者です。

PHPDocmentorをインストールする前にSmartyをインストールする必要があります。

ご確認ください。

id:dogdog555

インストールはしていて、phpDocumentor配下にある

Converter.incにて、Smarty.class.phpでインクルードしています。

念のため別のsmatryをインストールし、

該当箇所(includeしている箇所)に絶対パスで再指定、

etc/binのphp.iniファイルで対応付けがきちんとなるように対処し試してもだめです。

他の方が質問されているような文字化けについても、Converters配下のテンプレート、

iso〜を修正等も試し、修正済みです(上記トラブルとは関係ないと思っていますが)。

2011/01/11 22:41:53

コメントはまだありません

この質問への反応(ブックマークコメント)

「あの人に答えてほしい」「この質問はあの人が答えられそう」というときに、回答リクエストを送ってみてましょう。

これ以上回答リクエストを送信することはできません。制限について

絞り込み :
はてなココの「ともだち」を表示します。
回答リクエストを送信したユーザーはいません