いまRubyのバージョン1.8.8をリリースするかどうかの議論がされています(http://redmine.ruby-lang.org/issues/show/4207)。

Rubyの最新の安定板は1.9.2ですので、古い1.8系列に新しいバージョンを出すべきなのか、出すのならどのような位置付けで、どのような機能を盛り込むべきなのか。
私はコア開発者ではありませんが、この議論の参考になればと思いアンケートをさせていただきます。
1.8.8についてのご意見をください。

回答の条件
  • 途中経過を公開
  • 男性,女性
  • 13歳以上,20代未満,20代,30代,40代,50代,60代以上
  • 登録:2011/01/16 23:58:21
  • 終了:2011/01/17 07:27:32

回答(100 / 100件)

Q01あなたが主に使っているRubyのバージョンは何ですか?(CRuby限定で)(択一)

1.8.6以下6
1.8.711
1.8 trunk4
1.9.14
1.9.212
1.9 trunk63
合計100

Q021.8.8をリリースしてほしいですか?(択一)

はい15
いいえ85
合計100

Q031.8.8に一番望むことはなんですか?(択一)

1.9の機能をバックポート4
1.9への移行を支援する機能2
バグ修正2
安定性の向上76
(JRubyなど)他のRuby処理系との互換性向上2
長期間のサポート3
1.8.8は必要ない(Q2.で「いいえ」)11
合計100

Q04(1.9に移行していない方へ)移行しない理由はなんですか?(複数選択)

使っているライブラリが1.9に対応していない10
使っているフレームワーク(Railsなど)が1.9に対応していない4
1.8で作成したプログラムが多く移行が大変8
Encodingの仕組がよくわからない8
1.9はまだ十分に安定していない3
1.8で十分77
1.9の資料が少ない5
会社のルールで1.8を使うと決まっている4
合計100

集計

×
  • id:nuna
    みなさんご協力ありがとうございます。この結果をruby-devに投げてみようと思います。
    しかし、1.9 trunk利用者が思ったより多くて驚きました。

この質問への反応(ブックマークコメント)

「あの人に答えてほしい」「この質問はあの人が答えられそう」というときに、回答リクエストを送ってみてましょう。

これ以上回答リクエストを送信することはできません。制限について

絞り込み :
はてなココの「ともだち」を表示します。
回答リクエストを送信したユーザーはいません