ML115 G5にCentOS 5.1をインストールできません。

(インストール画面でRAID0+1(ハードディスク)を検出しない。認識しない。)

オンボードRAID(0+1)を
2TBHDDx4台(BIOS上では3.6TB程度で認識)で構成しました。
BIOS上では全く問題無く認識されています。

DVDからのインストール、netinstallどちらも試しましたが、
[boot: linux dd]とし、USBメモリでRHEL5.1用のnVIDIA RAIDドライバ
を読み込ませると、読み込んでいる表示が出ますので、ここまでは認識しているようです。

しかし、インストール画面でドライブを選択する画面では、
ドライバをインストールしたUSBメモリのドライブ(領域)だけが検出され、
RAIDどころか、ハードディスクを一台も認識しません。

実はML115 G5は二台購入しており、同時並行で作業を進めているのですが、
全く同じ症状でハードディスクを検出せず、CentOSのインストールを続行できません。
最初はUSBメモリ経由でドライバを読み込ませているから悪いんだと思い、
CDに焼いたり、イメージをチェック(MD5)してみたりしましたが、何の問題も無いようでした。

↓続きはコメントをご確認ください。

回答の条件
  • 1人1回まで
  • 登録:2011/01/18 14:30:45
  • 終了:2011/01/25 14:35:02

回答(1件)

id:deflation No.1

deflation回答回数1036ベストアンサー獲得回数1262011/01/18 15:01:29

ポイント60pt

CD起動可能なKNOPPIX6.0.1CD日本語版を使い、qtpartedコマンドでパーティションを作ってからCentOSをインストールしてみてください。

id:qwenty

qtpartedではなく、fdiskで下記の一部を実施してみましたが、

認識されませんでした。

http://www37.atwiki.jp/centos-homeserver/pages/20.html

WD20EARSは諦めようかな。。

2011/01/18 17:09:48
  • id:qwenty
    同じ構成で過去に二回ほど
    ML115 G5にCentOS5.1をインストールしたことがあり、全く同じ手順でしたが、
    何の問題無くインストールできました。
    違いといえば、2TBx4ではなく、その当時は1TBx4だったことでしょうか。(RAID0+1)

    三日以上格闘しており、困り果てています。
    どなたかお力を貸していただけないでしょうか。本当に困っています。

    【補足】
    ・オンボードRAIDを無効にすると、二台とも sda~sddまで四台認識し、
    フォーマット、インストール、ブートまで確認できました。
    オンボードRAIDを有効にすると、全くハードディスクを認識しません。
    ・5.1用のRAIDドライバで5.1~5.5までnetinstallで試しましたが、全滅。
    ・4.4用のRAIDドライバもあるので、4.4も試してみましたが、効果無し。
    ・[boot: linux dd nodmraid]は試したが効果無し。

    5.1用のRAIDドライバ
    http://goo.gl/nUony

    4.4用のRAIDドライバ
    http://goo.gl/2gdOw

    【手順】(CentOS5.1で5.1用のドライバを使用したい)
    http://goo.gl/nGsAi
  • id:seble
    HDは例のアレじゃなくて?
    (WDのEARS)
  • id:qwenty
    え?例のあれです。型番はWD20EARSです。
    気になります。WD20EARSは地雷だったのでしょうか。WD20EARSx4 WD20EARSx4です。相性とか?
  • id:b-wind
    インストールしようとしている CentOS は i386 と x86_64 のどちらですか?
    ドライバ自体は x86_64 用の物を使用しようとしているようですが…。

    あとはドライバが対応しているカーネルバージョンが変わってるとかかな…。
    DVD からのインストールなら問題は無いとは思うんだけど。
  • id:qwenty
    x86_64です。
    DVDからのインストールも駄目でした。
  • id:seble
    http://www.yuuan.net/blog/index.php?itemid=412
    地雷と言うと語弊があるけど、物理セクタが変わっているから難易度高し。
    俺が買った個体はどうもおかしくて、結局、初期不良として交換しました。
    (交換された新品は未開封のままヤフオク行きだったので、本当の所は分かりません)
  • id:qwenty
    sebleさん、本当にありがとうございます。涙
    いま、標準で付いてきた160GBのHDDx2台でRAID1を構成したところ、
    RAIDドライバはそのまま(RHEL5.1)で、CentOS正常に認識しました。
    どうやら、そのAdvanced Formatとやら原因のようです。
    メモリなどと違い、ハードディスクにこういったチェックが必要だとは全く考えていませんでした。
    ここで質問しなければ、いまも格闘していたことだと思います。
    本当にありがとうございます。
    この質問がみんなの役に立つといいです。Centos RAID 認識しない でググっても見つからない訳です。
    この三日間を考えると死にたくなってきた。
  • id:b-wind
    WDxxEARS シリーズは確かに地雷だけど、それはパフォーマンス面が主で認識すらしないってのは珍しいね。
    とはいえ、ディスク交換だけで対応できたんならそこがネックだったと判断するしかなさそう。

    今後 2TB 以上のHDDが出る度にこういうことを心配しないといけないのは面倒だね。
  • id:deflation
    fdiskには2TBの壁があるんですよ。
    qtpartedかpartedを使って下さい。
  • id:qwenty
    fdiskの2TBの壁って2TBまでのパーティションは問題なく引けるのでは?よく分からないけど、
    partedでやってみました。
    http://blog.livedoor.jp/hiroumauma/archives/1313205.html
    を参考に
    sudo parted /dev/sda
    unit s
    mkpart primary 54s -1s
    quit を四台分。フォーマットはインストール画面で出来るのでしませんでした。
    結果、やっぱり認識されませんでした。
    これ以上は技術も無いので、諦めるしかないかな。。ありがとうございます。

この質問への反応(ブックマークコメント)

「あの人に答えてほしい」「この質問はあの人が答えられそう」というときに、回答リクエストを送ってみてましょう。

これ以上回答リクエストを送信することはできません。制限について

絞り込み :
はてなココの「ともだち」を表示します。
回答リクエストを送信したユーザーはいません