flashをパブリッシュしたのですが、表示されません。

ムービーが再生されていないようです。

バージョンはFlash8 Actionscript2.0です。

元々サーバにswfがアップしてあり、それをアップロードして差し替えようと
したのですが、動きません。

ムービーのサイズなどは同じです。
中身もほとんど同じです。ムービーからの外部リンクURLを変えただけです。
ローカルでは無事再生されます。

オブジェクトタグもよく見たのですが、パスなどの記述は間違っていません。
一箇所だけidが id=abc.swf(サーバ) id=abc(ローカル) と.swfがあるかないか、といった
ところだけが違っています。

サーバのHTMLはちょっと簡単には書き換えられないので(立場上)、なんとか
このままアップロードしたswfを使いたいのですが、、、

Flashのパブリッシュ設定などをさわることによって解決できないでしょうか?

よろしくお願いします。

回答の条件
  • 1人5回まで
  • 13歳以上
  • 登録:2011/04/06 18:51:18
  • 終了:2011/04/07 09:55:37

回答(2件)

id:asuka645 No.1

あすか回答回数856ベストアンサー獲得回数972011/04/06 19:53:37

ポイント35pt

問題のHTMLやASが無いので何とも言えませんが、以下の点を確認お願いします。

  1. ブラウザのURLに直接swfファイルを指定すると表示されますか?→それでも表示されないとすると、ASの中で読み込んでいるパラメータのパスが間違っていませんか?
  2. Webサーバ側ないしはHTMLにオブジェクトのキャッシングの設定がありませんか?→あったらキャッシュをクリアしてみてください。
id:mini-panda

1.2ともに試しました。

ブラウザのURLに直接swfファイルを指定しても空白のままでした。

右クリック→再生を押すと見られるのですが、、、

ASの中で読み込んでいるパラメータのパス → すみません、ここが分からないので説明してもらえると助かります。

よろしくお願いします。

2011/04/06 21:01:20
id:asuka645 No.2

あすか回答回数856ベストアンサー獲得回数972011/04/06 22:10:48

ポイント35pt

もう一つ思い当たる原因ですが、SWFファイルをアップロードする時、たとえばFTPのアスキーモードにしていませんか? ご確認ください。


ASの中で読み込んでいるパラメータのパス → すみません、ここが分からないので説明してもらえると助かります。

詳しくは「ターゲットパス」をご覧いただきたいのですが、絶対パスの指定ミスは無いでしょうか?

id:mini-panda

ターゲットパス、リンクをありがとうございました。

ただ、これは問題なさそうです。FTPも問題無しです。

右クリックして、メニューから再生を選ぶと表示されます。

もしパスが間違っているのなら、表示されないはずです。FTPもしかり。

よろしくお願いします。

2011/04/06 22:56:28

コメントはまだありません

この質問への反応(ブックマークコメント)

「あの人に答えてほしい」「この質問はあの人が答えられそう」というときに、回答リクエストを送ってみてましょう。

これ以上回答リクエストを送信することはできません。制限について

絞り込み :
はてなココの「ともだち」を表示します。
回答リクエストを送信したユーザーはいません