現在MacOS 10.6.7の買ったばかりの状態からhttpd.confでPHPを有効にし、サイトのドキュメントルートを変えるだけの作業をしたところです。

これからPEARをインストールしたいのですが、すでに動いているPHPのバージョン(5.3.4)が新しくてgo-pear.phpも使えないようです。
どのようにしてPEARをインストールすればよいでしょうか。
なお、MacPortsやXAMPP等は使うつもりりません。

回答の条件
  • URL必須
  • 1人2回まで
  • 13歳以上
  • 登録:2011/04/09 12:40:13
  • 終了:2011/04/14 10:57:13

ベストアンサー

id:asuka645 No.3

あすか回答回数856ベストアンサー獲得回数972011/04/09 19:27:57

ポイント40pt

Could not open input file: go-pear.pharと言われてしまいます。

"http://pear.php.net/go-pear.phar" をダウンロードしましたか?

id:wackey

すいません。ダウンロードして、サイド実行してみたのですが、

Sorry! Your PHP version is too new (5.3.4) for this go-pear.

Instead use http://pear.php.net/go-pear.phar for a more stable and current

version of go-pear, more suited to your PHP version.

と言われてしまいます。ダウンロードの仕方が悪いのでしょうか?

20:00加筆:

できました。普通にhttpでダウンロードしてきたものをコマンドでたたいたら、PEARの画面になりました。ありがとうございます。

あとはパスの設定等が残っています。

2011/04/09 20:01:18

その他の回答(2件)

id:asuka645 No.1

あすか回答回数856ベストアンサー獲得回数972011/04/09 13:00:01

ポイント27pt

go-pear.phpの代わりに "http://pear.php.net/go-pear.phar" を使って下さい。

実行時は以下の通り。

php -d detect_unicode=0 go-pear.phar
id:wackey

Could not open input file: go-pear.pharと言われてしまいます。

2011/04/09 13:40:46
id:online_p No.2

online_p回答回数1153ベストアンサー獲得回数592011/04/09 18:44:25

id:wackey

ありがとうございます。今のところPHPを入れ直すことは考えていません。

2011/04/09 20:00:34
id:asuka645 No.3

あすか回答回数856ベストアンサー獲得回数972011/04/09 19:27:57ここでベストアンサー

ポイント40pt

Could not open input file: go-pear.pharと言われてしまいます。

"http://pear.php.net/go-pear.phar" をダウンロードしましたか?

id:wackey

すいません。ダウンロードして、サイド実行してみたのですが、

Sorry! Your PHP version is too new (5.3.4) for this go-pear.

Instead use http://pear.php.net/go-pear.phar for a more stable and current

version of go-pear, more suited to your PHP version.

と言われてしまいます。ダウンロードの仕方が悪いのでしょうか?

20:00加筆:

できました。普通にhttpでダウンロードしてきたものをコマンドでたたいたら、PEARの画面になりました。ありがとうございます。

あとはパスの設定等が残っています。

2011/04/09 20:01:18

コメントはまだありません

この質問への反応(ブックマークコメント)

「あの人に答えてほしい」「この質問はあの人が答えられそう」というときに、回答リクエストを送ってみてましょう。

これ以上回答リクエストを送信することはできません。制限について

絞り込み :
はてなココの「ともだち」を表示します。
回答リクエストを送信したユーザーはいません