imagemagick6.2.8で

convert -list threshold
を実行すると、
convert: unrecognized list type `threshold'.
と出るのですが、これはimagemagickのインストールがうまくいってないからでしょうか?
考えられる原因を教えてください。

回答の条件
  • 1人5回まで
  • 13歳以上
  • 登録:2011/07/13 16:14:48
  • 終了:2011/07/14 20:53:39

ベストアンサー

id:rouge_2008 No.3

rouge_2008回答回数594ベストアンサー獲得回数3512011/07/14 20:13:19

ポイント120pt

ありがとうございます。

追加情報は少しですが回答させていただきます。


こちらでも6.2.8で試してみましたが、同じ結果になりました。

「Halftone」をすべて試すには、バージョン6.2.9-5以降が、「Circles」を試すには6.6.5-6以降をインストールする必要があります。(thresholds.xmlで確認)

※6.6.5-6以降は、以下のページで紹介されているすべてのパターンが使用できます。(現在の最新バージョンは6.7.1-0)

http://www.imagemagick.org/script/command-line-options.php#ordered-dither

id:MrB

長々とお付き合い頂き、誠にありがとうございました。

また、機会があればお願いします。

2011/07/14 20:52:17

その他の回答(2件)

id:km1981 No.1

km1981回答回数429ベストアンサー獲得回数492011/07/13 19:30:46

ポイント30pt

パラメータが足りないのだと思います


次のように指定します

$ convert -threshold 閾値 変換前画像ファイル名 変換後画像ファイル名


http://d.hatena.ne.jp/longicorn/20100223

id:MrB

ご回答ありがとうございます。

そして、言葉足らずですみません。

ご指摘の使い方は知っているのですが、今回は別の使い方になります。

http://www.imagemagick.org/script/command-line-options.php#ordered-dither

の部分に書かれている

To print a complete list of the thresholds that have been defined, use the -list threshold option.

を試しているのですが、エラーになるので、なぜなのだろうと思い質問させていただきました。

引き続きご回答お待ちしています。

2011/07/13 19:40:03
id:i_kumagoro No.2

i_kumagoro回答回数170ベストアンサー獲得回数582011/07/13 22:26:47

ポイント50pt

ソースコードを確認しましたが、ImageMagick 6.2.8での-listオプションでは引数thresholdをサポートしていません。もっと新しいものを使う必要があります。

id:MrB

ありがとうございます。

バージョンアップして再度試してみます。

2011/07/14 08:27:40
id:rouge_2008 No.3

rouge_2008回答回数594ベストアンサー獲得回数3512011/07/14 20:13:19ここでベストアンサー

ポイント120pt

ありがとうございます。

追加情報は少しですが回答させていただきます。


こちらでも6.2.8で試してみましたが、同じ結果になりました。

「Halftone」をすべて試すには、バージョン6.2.9-5以降が、「Circles」を試すには6.6.5-6以降をインストールする必要があります。(thresholds.xmlで確認)

※6.6.5-6以降は、以下のページで紹介されているすべてのパターンが使用できます。(現在の最新バージョンは6.7.1-0)

http://www.imagemagick.org/script/command-line-options.php#ordered-dither

id:MrB

長々とお付き合い頂き、誠にありがとうございました。

また、機会があればお願いします。

2011/07/14 20:52:17
  • id:rouge_2008
    小文字で指定しているのが原因ではないでしょうか?
    以下を実行してみてください。

    convert -list Threshold

    上記で駄目だった場合は、「identify -list list」を実行して、結果に「Threshold」が出力されるか確認してみてください。

    http://www.imagemagick.org/script/command-line-options.php#list
  • id:rouge_2008
    大文字・小文字は関係ないみたいですね。失礼しました・・・
    やはりバージョン6.2.8では対応していないのかもしれません。
    「identify -list list」を実行して、結果に「Threshold」が表示されるか確認してみてください。
  • id:rouge_2008
    何回もすみません。
    6.2.8-6でordered-ditherにhalftone patternsの2x1, 4x1, 6x1, 8x1が許可されたとありますので、6.2.8でもordered-ditherを使用できる可能性はあります。
    http://studio.imagemagick.org/pipermail/magick-announce/2006-August/000034.html
    --------------------------------------------
    2006-07-24 6.2.8-6 Glenn Randers-Pehrson <glennrp at glenn...>
    Extend ordered-dither to accept a few more values 2x1, 4x1, 6x1, and 8x1 are
    halftone patterns.
    --------------------------------------------

    上記ページで6.2.8-0以降の変更が確認できますが、他にordered-ditherに関する変更はありません。
    「threshold」「checks」「o2x2」等に関しては、6.2.8のどのバージョンでも使用できるのではないかと思いますので、以下で実行できるか確認してみてください。

    convert "/home/xxxxx/yyyy.jpg" -ordered-dither threshold "/home/xxxxx/yyyy-im.jpg"
    convert "/home/xxxxx/yyyy.jpg" -ordered-dither o2x2 "/home/xxxxx/yyyy-im.jpg"

    ※画像のパスは環境に合わせて変更してください。
    ※「Halftone」の一部または全部、および「Circles」は使用できないと思います。
    (6.5.1-0で「Halftone」はすべてありましたが、「Circles」はまだ追加されていませんでした。)
  • id:MrB
    rouge_2008さん、いろいろとコメントありがとうございます。
    ポイントを幾分差し上げたいのですが、すべてコメントのため、差し上げることができません。
    何でも構いませんので、早めに回答欄に記入頂けると助かります。

    ちなみに
    convert -list Threshold

    convert: unrecognized list type `Threshold'.

    identify -list list

    identify: unrecognized list type `list'.

    になりました。

    今回やりたいのはordered-ditherのHalftoneなのですが、どうにもうまくいかないと思ったらバージョンのようですね。
    -ordered-dither 4x1は実行はできるのですが、思った結果にならないので。

    ちなみに、
    -ordered-dither threshold と-ordered-dither o2x2

    invalid argument for option
    になりました。

    詳しい解説まことにありがとうございました。
  • id:rouge_2008
    たくさんのポイントとベストアンサーをどうもありがとうございました。

    > -ordered-dither threshold と-ordered-dither o2x2 は invalid argument for option
    になりました。

    すみません。画像の出力までは確認していませんでした。
    エイリアス(「threshold」は「1x1」、「o2x2」は「2x2」)を指定した場合は、エラーになりませんでしたが、真っ白な画像が出力されますね。
    最新版では問題なく動作しましたので、インストールする場合はなるべく新しいバージョンをインストールしてみてください。

    それから、ご存知かもしれませんが参考にしてください。(レベル指定の方法など)
    http://www.imagemagick.org/Usage/bugs/ordered-dither/
    http://kyle-in-jp.blogspot.com/2008/04/imagemagick_1233.html

この質問への反応(ブックマークコメント)

「あの人に答えてほしい」「この質問はあの人が答えられそう」というときに、回答リクエストを送ってみてましょう。

これ以上回答リクエストを送信することはできません。制限について

絞り込み :
はてなココの「ともだち」を表示します。
回答リクエストを送信したユーザーはいません