1326379980 Androidアプリで、import com.google.android.maps.GeoPoint; としようとすると、

「インポートされた com.google は見つかりません」とエラーになってしまいます。

Hello Worldはエミュレータ上で動いたので
Androidアプリを勉強しようと、公開されているプロジェクトをzipで落としてきて
インポートしたのはいいですが、このエラーが出て実行できません。

多分、google API(?)とか呼ばれている 何かのライブラリがインストールされていないのか
見つからないのだと思います。

関係ないかもしれませんが、manifestには
<uses-library android:name="com.google.android.maps"/>
と記入されています。
ターゲットを Google APIsとかにしても駄目なようです。

回答の条件
  • 1人5回まで
  • 13歳以上
  • 登録:2012/01/12 23:53:05
  • 終了:2012/01/19 23:55:03

回答(2件)

id:kodairabase No.1

kodairabase回答回数661ベストアンサー獲得回数802012/01/13 00:57:01

ポイント50pt

manifestを以下のように変更してみてください。

<uses-library>
    android:name="com.google.android.maps"
</uses-library>
id:suzume_oyado

うーん。やってみましたが、駄目なようです...

2012/01/13 22:21:20
id:a-kuma3 No.2

a-kuma3回答回数4363ベストアンサー獲得回数18002012/01/13 01:17:19

ポイント50pt

http://code.google.com/intl/ja/android/add-ons/google-apis/maps-overview.html

To run your Maps-based application in the Android Emulator, you need to set up an Android Virtual Device (AVD) that is configured to use the Google APIs add-on.

とあります。

http://webcache.googleusercontent.com/search?q=cache:TAix82ApD7sJ:doruby.kbmj.com/oneafter999_on_rails/20110725/Android_Google_Maps_+&cd=1&hl=ja&ct=clnk
# Google のキャッシュです
上記でも、Google APIs のインストールとは別に、AVD の作成という手順があります。


因みに、manifest は正しいと思いますよ。
先にあげた code.google.com のページでも、Manifest File はこんな感じだ、ってありますし。

<manifest xmlns:android="http://schemas.android.com/apk/res/android"
 package="com.example.package.name">
  ...
  <application android:name="MyApplication" >
    <uses-library android:name="com.google.android.maps" />
    ...
  </application>
  ...
</manifest>

Android アプリの開発なんてしたことは無くて、回答内容としては、コメントレベルなのですけれど、
アンカーとかが見にくいので、回答に書いちゃいました。
不適当な内容であれば、容赦なく、ゼロポイントにしてください。

id:suzume_oyado

>To run your Maps-based application in the Android Emulator

なので「動作させる為には」という事でしょうかね…。
試しにAVDを作ってみましたが、駄目なようです。

com.googleに赤波線が付いているので まずここの名前解決(?)が
できていないので、そこをなんとかしないといけないのかな...
うーむ・・。

2012/01/13 22:22:32

コメントはまだありません

この質問への反応(ブックマークコメント)

「あの人に答えてほしい」「この質問はあの人が答えられそう」というときに、回答リクエストを送ってみてましょう。

これ以上回答リクエストを送信することはできません。制限について

絞り込み :
はてなココの「ともだち」を表示します。
回答リクエストを送信したユーザーはいません