サーバー(SAKURA VPS)のphpバージョンを5.1.6→最新(5.2.6?)に上げようと思うのですが、上げた場合に考えられる不具合は何がありますでしょうか?

現在はサーバー内でxoops2.0.16a、XCL2.1、phpアップローダー(社内用)などが稼働中です。また、アップグレードの方法でもOKなのでご教授ください<(_ _)>

回答の条件
  • 1人5回まで
  • 13歳以上
  • 登録:2012/05/24 17:42:26
  • 終了:2012/05/29 19:24:53

回答(2件)

id:TransFreeBSD No.1

TransFreeBSD回答回数668ベストアンサー獲得回数2682012/05/24 19:23:48

ポイント50pt

最新と言えば5.4.3になりますが、5.3系もメンテされてますし、そっちが良い気がします。

とか言いつつユーザーではないので確かな事は言えませんが。
あと、アプリケーションの方は、広く使われているならたぶん大丈夫じゃないでしょうか?
元々のソースに含まれているREADMEとかINSTALLの記載記載を確認してはどうでしょう。

ただ、なんにせよ、まずは(作業ミス対策とかも含め)バックアップを取り、手元に同じ環境を作って、手順の確認、動作の確認、(いざと言うときのための)元に戻す手順の確認なんかは行うべきでしょう。特に自作のモジュールとか変更点とかあると思わぬ結果とかおこりえますし。

一応、5.1→5.2→5.3での影響の出そうな所は以下になると思います。

id:kaji0245

ご回答ありがとうございます、参考にさせていただきます。

2012/05/29 19:24:34
id:oil999 No.2

oil999回答回数1728ベストアンサー獲得回数3202012/05/27 10:11:37

ポイント50pt

PHPの最新版は5.4.3です。

PHP 5.3では、ereg系の正規表現関数が廃止されたのが大きな変更点です。
ereg 系の正規表現関数が廃止された。
http://gihyo.jp/dev/feature/01/php53

PHP 5.4では、セーフモード、マジッククォート、参照渡しなどが廃止されています。

これらの点に注意してバージョンアップを行う必要があります。

id:kaji0245

ご回答ありがとうございます、参考にさせていただきます。

2012/05/29 19:24:39
  • id:rouge_2008
    XOOPS 2.0、XCLともに5.2系では特に問題は発生しないはずです。
    ただし、5.3系では問題が発生するようですので、ローカル等で動作確認してからにした方が良さそうです。
    おそらく5.4系にもまだ対応していません。

この質問への反応(ブックマークコメント)

「あの人に答えてほしい」「この質問はあの人が答えられそう」というときに、回答リクエストを送ってみてましょう。

これ以上回答リクエストを送信することはできません。制限について

絞り込み :
はてなココの「ともだち」を表示します。
回答リクエストを送信したユーザーはいません