匿名質問者
匿名質問者匿名質問者とは「匿名質問」を利用して質問した質問者。
「匿名質問」では、ユーザー名を公開せずに匿名の質問ができます。
詳しくはこちら

さくらのレンタルサーバーでとあるパッケージをgemインストールしようとしたところ、

nokogiriのインストールで
nokogiri requires Ruby version >= 1.9.2.
というerrorが出てしまいました.
ruby -vでは1.9.3と認識されています。
解決方法をご存知の方はいらっしゃいますか

回答の条件
  • 1人5回まで
  • 13歳以上
  • 登録:2013/08/09 15:06:12
  • 終了:2013/08/16 15:10:03

回答(1件)

匿名回答1号 No.1

匿名回答1号「匿名質問」を利用した質問に回答すると「匿名回答○号」と匿名で表示されます。
「匿名質問」では、ユーザー名を公開せずに匿名の質問ができます。
詳しくはこちら
2013/08/09 17:15:44

ユーザーディレクトリにruby1.9.3をインストールしたなら環境変数でPATH指定しましょう。
http://stackoverflow.com/questions/17204152/nokogiri-error-when-running-bundle-install

Turned out I was using the default system Ruby (and thus installing all the gems there in /Library/Ruby/Gems) even though rbenv points to ruby-1.9.3 so that's why Nokogiri was complaining.

Fixed this by adding this to $PATH, so rbenv loads before the system ruby:

export PATH="$HOME/.rbenv/bin:$PATH"

コメントはまだありません

この質問への反応(ブックマークコメント)

「あの人に答えてほしい」「この質問はあの人が答えられそう」というときに、回答リクエストを送ってみてましょう。

これ以上回答リクエストを送信することはできません。制限について

絞り込み :
はてなココの「ともだち」を表示します。
回答リクエストを送信したユーザーはいません