「はてなブログ」で「IE 互換モード」の指定を変更する方法についてご存じの方いらっしゃいましたら、教えてください。


ブログに IE11 の WebGL 機能を使ったコンテンツを載せてみたいのですが、はてなブログ内部で、以下のIE互換モードが指定がされている為に、表示してくれないようです。。。
<meta http-equiv="X-UA-Compatible" content="IE=7; IE=9; IE=10" />

回答の条件
  • 1人5回まで
  • 13歳以上
  • 登録:2013/09/12 02:15:37
  • 終了:2013/09/19 02:20:04
id:cx20

質問者から

cx202013/09/12 08:21:55

該当ブログは以下になります。

■ はてなブログで JavaScript を使ってみるテスト(その3)
http://cx20.hatenablog.com/entry/2013/09/12/012206

Firefox / Chrome では、正しく WebGL のコンテンツを表示することを確認しています。

回答(0件)

回答はまだありません

  • id:windofjuly
    うぃんど 2013/09/12 05:40:07
    X-UA-Compatible 指定は一番最初に行うくらいでないとダメなので
    head部を自由にいじれない今の仕様では無理だと思います。

    ハックできないかとこんなものを設定の色々な部分に入れてみましたが、
    残念なことに(おぃおぃ)HTMLエンティティにちゃんと変換されちゃいました…。
    " /><meta http-equiv="X-UA-Compatible" content="IE=100

    はてながIE11に対応するのを待つしかないでしょう…。

    この程度なのでコメントにしておきます。

    優れたハッカーが通りすがってくれますように…。
  • id:cx20
    うぃんど さん、ありがとうございます。
    やはり、はてな側で対応してもらうしか無いんですかね。。。
  • id:cx20
    2014.04.13 時点で確認したところ、いつの間にか「IE=11」が追加されていたようです。

    <meta http-equiv="X-UA-Compatible" content="IE=7; IE=9; IE=10; IE=11" />

この質問への反応(ブックマークコメント)

「あの人に答えてほしい」「この質問はあの人が答えられそう」というときに、回答リクエストを送ってみてましょう。

これ以上回答リクエストを送信することはできません。制限について

絞り込み :
はてなココの「ともだち」を表示します。
回答リクエストを送信したユーザーはいません