PhpStormでPHPのinterpreterが設定できません…


[環境]
OS: Windows7 32bit
Server: Apache2.2
PHP: 5.4.7
PhpStorm: 7.1.2

Settigs > PHP からinterpreterを設定しようとしているのですが、
==================================
PHP Startup: Unable to load dynamic library 'c:\php\ext\php_pdo_firebird.dll' - 指定されたモジュールが見つかりません。
PHP Startup: Unable to load dynamic library 'c:\php\ext\php_pdo_oci.dll' - 指定されたモジュールが見つかりません。
==================================
というエラーが出てしまい、
PHP version: Not installed
Debugger; Not installed
と表示されてしまいます。

上記2つのモジュールがc:\php\extに存在しているのは確認済です。
また、php.iniにて上記モジュール読み込み部分がコメントアウトされているのも確認済です。
一度php.iniの上記モジュール読み込み部分をコメントアウトしたみたところ、エラーは出なくなったのですが、PHPとDebuggerがNot installedと表示されるのは変わりませんでした。

これは、どうやったら設定出来るようになるでしょうか?
一度phpを再インストールしたほうがいいでしょうか?
(xamppではなく、Apache、PHP、MySQL…全部個別で入れています)
ちなみに、localhost上でphpが動いているのは確認済です。

よろしくお願いします。

回答の条件
  • 1人5回まで
  • 13歳以上
  • 登録:2014/02/20 13:13:38
  • 終了:2014/02/27 13:15:03

回答(0件)

回答はまだありません

  • id:sheepsace
    php5.4.26をインストールし直したらエラーが出なくなりました。

    PHP version: Not installed
    Debugger: Not installed
    については、php.iniでのextensionの書き方を

    ×)extension=php_xdebug-2.2.3-5.4-vc9.dll
    ○)zend_extension="c:\php\ext\php_xdebug-2.2.3-5.4-vc9.dll"

    のように変更したら解決し、無事デバッグ出来ました。

この質問への反応(ブックマークコメント)

「あの人に答えてほしい」「この質問はあの人が答えられそう」というときに、回答リクエストを送ってみてましょう。

これ以上回答リクエストを送信することはできません。制限について

絞り込み :
はてなココの「ともだち」を表示します。
回答リクエストを送信したユーザーはいません