osCommerce-2.2mslj を XREA にインストールしようとしています。


osCommerce-2.2mslj を XREA にインストールしようとしているのですが、上手く行きません。

ffftpソフトにて必要なファイルをアップロードし、

http://xxxx/catalog/install/にアクセス→New Install

インストール情報入力画面

データベース・サーバに関する情報を入力→continue

すると、下記エラーメッセージが表示されます。

---------------------------------------------
Step 1: データベース・インポート

データベースへの接続テストが失敗しました。

エラー・メッセージ:

Access denied for user: 'ユーザー名@localhost' (Using password: YES)
---------------------------------------------

調べると、
「Access denied for user」とは、ユーザーにアクセス権がないことを示す。
「Using password: YES」は、アクセスにあたってパスワードが使われたことを示す。

とありました。

入力したデータベース・サーバの情報は合っていると思うのです。

何をどう、直せば先に進めるのか、調べきれずにいます。
どなたか、お知恵ををお貸しください。

回答の条件
  • 1人5回まで
  • 13歳以上
  • 登録:2014/09/15 13:20:23
  • 終了:2014/09/22 13:25:06

回答(0件)

回答はまだありません

  • id:sasada
     ユーザー名かホスト名(@localhost)かパスワードが間違っているのかと。
     全部が合っていたら、そのユーザーのデータベースへのアクセス権限が足りてないことになります。
     データベースの設定ですね~
  • id:hitomisato
    ありがとうございます!
    はずかしながら、データベースの設定をやりなおしたところ、先に進むことができました。
    ところが、

    --------------------------------
    新規インストール

    Step 2: osCommerce の設定

    設定ファイルの書き込みが成功しました。
    --------------------------------

    ここまで来て、catalog ボタンを押したところ、

    --------------------------------
    FATAL ERROR: register_globals is disabled in php.ini, please enable it!
    --------------------------------

    とのエラーメッセージが出ました。

    検索したところ、このメッセージはhttp://[your site]/catalog/installを開始したときに出ていることが多いようです。

    私のようにインストールが完了したあとにこのメッセージが表示される例はまだ見つけられていません。

    どのように直せば良いでしょうか。。知識不足で申し訳ないのですが、どなたかご教唆ください。


  • id:hitomisato
    oscommerceのメーリングリストに投稿したところ、

    > モジュール版PHPではregister_globalsをOnには出来ません。
    > CGIとして動かす場合にはphp.iniの中に設定を書く必要があります。
    >
    > 古いバージョンであればregister_globals=Offで動くものもあります。
    > http://sourceforge.jp/projects/tep-j/releases/p1428
    >
    > 新しいバージョンを使いたければサーバをXREAから他に変えた方が良い
    > です。Minibird(http://www.minibird.jp/)は管理パネルからPHPの環境
    > を変更出来ます。
    >
    > 最後にセキュリティ上、register_globalsはOffの方が望ましいです。
    > 対策は $_GET, $_POST, $_SERVER 等のスーパーグローバル配列を使用
    > してプログラム(ソースコード)を書き直すことです。
    >

    との回答を頂きました。
    古いバージョンをダウンロードしてインストールをやり直したところ、上手く行きました。

    php.ini の設定という記述は、検索するうち見かけたのですが、 php.ini がどこにあるものなのか、私にはわかりませんでした。
    「register_globalsはOffの方が望ましいです」とのことなので、上記で対処しました。

    ありがとうございました。

この質問への反応(ブックマークコメント)

「あの人に答えてほしい」「この質問はあの人が答えられそう」というときに、回答リクエストを送ってみてましょう。

これ以上回答リクエストを送信することはできません。制限について

絞り込み :
はてなココの「ともだち」を表示します。
回答リクエストを送信したユーザーはいません