ソフトなどの対応OSについて


例えば、あるソフトウェアでwindows vista対応とある場合は、そのOS以降の新しいOSも対応するのですか?

回答の条件
  • 1人50回まで
  • 登録:2015/10/11 22:26:43
  • 終了:2015/10/16 15:18:53

ベストアンサー

id:degucho No.1

degucho回答回数254ベストアンサー獲得回数682015/10/11 23:06:15

WindowsはMacに比べると互換性を重視しているため概ねそう考えて良いと思いますが
バージョンが上がるごとにセキュリティ関連が厳しくなっているので
特殊なこと(システムフォルダにアクセスしたりフォルダ構成が特定のバージョンを想定など)をしてるソフトだと正常に動作しない可能性があります。
また、ハードウェア付属のユーティリティなどはドライバが動作しないためあまりにバージョンが離れると動作しないことが多いです。

経験的にはVista以降なら大抵最新のWindows10でも動作しますが
XP時代のものは動かないことがあります。
(Virtual Storeなど)

その他の回答(1件)

id:degucho No.1

degucho回答回数254ベストアンサー獲得回数682015/10/11 23:06:15ここでベストアンサー

WindowsはMacに比べると互換性を重視しているため概ねそう考えて良いと思いますが
バージョンが上がるごとにセキュリティ関連が厳しくなっているので
特殊なこと(システムフォルダにアクセスしたりフォルダ構成が特定のバージョンを想定など)をしてるソフトだと正常に動作しない可能性があります。
また、ハードウェア付属のユーティリティなどはドライバが動作しないためあまりにバージョンが離れると動作しないことが多いです。

経験的にはVista以降なら大抵最新のWindows10でも動作しますが
XP時代のものは動かないことがあります。
(Virtual Storeなど)

id:tea_cup No.2

tea_cup回答回数1013ベストアンサー獲得回数1802015/10/12 20:52:39

アプリの作りによります。
外部のAPIを呼び出しているものは、OSがそのAPIをサポートしなくなると新しいAPIに対応するように書き換える必要があります。
SafeDiscやSecuROMといったDRM、Vista?8.1でもデフォルトでは動作しなくなっていた | スラド セキュリティ

各アプリの互換情報をwindows7の頃は、マイクロソフトが提供していましたが、windows10用の情報がまとまっているサイトは、見つけることができませんでした。

参考URI:(既に実際の情報にアクセスできなくなっている模様)
Windows 7 互換性情報|Microsoft atLife TIPS アーカイブ

コメントはまだありません

この質問への反応(ブックマークコメント)

「あの人に答えてほしい」「この質問はあの人が答えられそう」というときに、回答リクエストを送ってみてましょう。

これ以上回答リクエストを送信することはできません。制限について

絞り込み :
はてなココの「ともだち」を表示します。
回答リクエストを送信したユーザーはいません