Wordpress 3.3.1の不具合につき教えて下さい。


Webhostingpadという、サービスの良くないサーバーでWPで作成したサイトを4つ運営していますが、数年間放置してしまいました。
ログインしてみると、サイドバーのみ表示されて、メインの部分が空白で表示されます(画像参照)
どこをクリックしても右側には何も表示されません
他3つのサイトも同じ状態です

下記試しました
●旧サーバーから、wp-content を新サーバーに移動
●wp-content フォルダー以外は、WP 4.3.1 のファイル使用
●旧サーバーからDBをエクスポートして、新サーバーにインポート
●新サーバーーのwp-config.php修正

結果
wp-admiinでログイン時にパスワードが認識されない。
phpMyadmin でDBを見たところ、一部データが不完全な形でインポートされていることが判明
phpMyadminで不完全なテーブルを再度インポートするが、wp_usermeta のみインポートするとエラーが出る。
wp-adminでログインできるようになるがログイン後
you do not have sufficient permissions to access this page
というメッセージが表示される

どのように対処したらよいでしょか?

※投稿と写真、URLのデータのみ継承されれば、テーマやコメントは不要です

回答の条件
  • 1人5回まで
  • 13歳以上
  • 登録:2015/11/19 20:10:44
  • 終了:2015/11/26 20:15:03

回答(0件)

回答はまだありません

  • id:rouge_2008
    同様の現象には遭遇した事がないので、解決するか分かりませんが・・・
    いくつか気になった点があります。

    1.アップグレード時にプラグインを停止させたでしょうか?

    ・管理パネルにアクセスできないときに全プラグインを停止するには?
    http://wpdocs.osdn.jp/FAQ/%E3%83%88%E3%83%A9%E3%83%96%E3%83%AB%E3%82%B7%E3%83%A5%E3%83%BC%E3%83%86%E3%82%A3%E3%83%B3%E3%82%B0#.E7.AE.A1.E7.90.86.E3.83.91.E3.83.8D.E3.83.AB.E3.81.AB.E3.82.A2.E3.82.AF.E3.82.BB.E3.82.B9.E3.81.A7.E3.81.8D.E3.81.AA.E3.81.84.E3.81.A8.E3.81.8D.E3.81.AB.E5.85.A8.E3.83.97.E3.83.A9.E3.82.B0.E3.82.A4.E3.83.B3.E3.82.92.E5.81.9C.E6.AD.A2.E3.81.99.E3.82.8B.E3.81.AB.E3.81.AF.EF.BC.9F
    ※FTP等で接続して、「wp-content」内に空の「plugins」ディレクトリを作成する方法が簡単だと思います。(ドキュメントではフォルダ名に誤記がありますので注意してください。)
    ※手順2および3は、作業が完了して正常にログインできるようになってからで大丈夫です。(フォルダは元に戻しても大丈夫ですが、WordPress本体の正常動作確認後、各プラグインのファイルを最新版と入れ替えてから有効にしてください。)

    2.一部データが不完全な形でインポートされていたという事ですが、どのように不完全だったのでしょうか?
    また、「wp_usermeta」以外に不完全だったのはどのテーブルですか?
    最初のインポート時に何かエラーは表示されませんでしたか?
    また「wp_usermeta」テーブルのインポート時に表示されたエラーはどのような内容でしたか?

    3.その後ログインできるようにするために何を実行したのでしょうか?


    ※旧サーバーのデータベースはまだそのまま残してあるのでしょうか?
    もしあるのでしたら、再度テーブルごとにバックアップをとってみてください。
    プラグイン停止で正常に動作しないようでしたら、再度データベースのリストアから行った方がいいと思います。


    ※「wp_usermeta」テーブルで「meta_key」が「wp_capabilities」と「wp_user_level」のデータをそれぞれ次のように修正するとログインできたという情報もいくつか見つかりました。

    ・wp-admin, You do not have sufficient permissions to access this page.
    https://wordpress.org/support/topic/wp-admin-you-do-not-have-sufficient-permissions-to-access-this-page
    -------------------------------------------------------
    wp_capabilities should be a:1:{s:13:"administrator";s:1:"1";}

    wp_user_level should be 10
    -------------------------------------------------------


    ※いろいろ書きましたが、旧バージョンと同じバージョンで新規インストールして、まずはその状態で正常に動作するか確認してもいいと思います。(問題なく動作するようでしたら、旧データベースのバックアップ(エクスポートしたファイル)をリストアしてみてください。プラグインも動作が確認できてから有効にします。)
    過去のバージョンもリリース一覧ページからダウンロード可能になっています。

    https://ja.wordpress.org/releases/

この質問への反応(ブックマークコメント)

「あの人に答えてほしい」「この質問はあの人が答えられそう」というときに、回答リクエストを送ってみてましょう。

これ以上回答リクエストを送信することはできません。制限について

絞り込み :
はてなココの「ともだち」を表示します。
回答リクエストを送信したユーザーはいません