1489752395 はてなブログにVideo Light Boxというツールを組み込んだのですが、他の修正をしたら動かなくなってしまいました。


他の修正:

http://q.hatena.ne.jp/1489658552

Video Light Boxというツールがあります。これは、Webページ上の動画サムネイル画像をクリックするとウィンドウが開いてYouTubeが再生できるというもので、多数の動画を1つのページに埋め込むのに適しています。

これを下記ページに設置していたのですが、他の問題を解決したら、動かなくなってしまいました(リンク先をご参照下さい)。

http://www.weed-7777.me/entry/2017/03/10/171605

コンソールには404エラーだけが返ってきます:

www.youtube.com/v/va23YOI5O3Q?autoplay=1&rel=0&enablejsapi=1&playerapiid=ytplayer:1 GET https://www.youtube.com/v/va23YOI5O3Q?autoplay=1&rel=0&enablejsapi=1&playerapiid=ytplayer 404 ()
Navigated to https://www.youtube.com/v/va23YOI5O3Q?autoplay=1&rel=0&enablejsapi=1&playerapiid=ytplayer

しかし、ローカルにHTMLファイルを置いてサムネイルをクリックすると問題なく再生されます。

どうしたらいいでしょうか?よろしくお願いいたします。

回答の条件
  • 1人1回まで
  • 13歳以上
  • 登録:2017/03/17 21:06:35
  • 終了:2017/03/24 21:10:08

回答(0件)

回答はまだありません

  • id:a-kuma3
    ローカルにファイルを置いたときの挙動はよく分からないのですが、YouTube 動画のところをクリックすると、Firefox では以下のようなログがコンソールに出ます。
    >>
    21:30:28.394 GET https://www.youtube.com/v/SvXEllK4JUg [HTTP/2.0 404 Not Found 121ms]
    <<
    で、この URL をアドレスバーで直打ちしたときに、コンソールに出るメッセージがこれ。
    >>
    21:31:56.725 GET https://www.youtube.com/v/SvXEllK4JUg [HTTP/2.0 200 OK 134ms]
    21:31:57.167 古いスタイルの YouTube Flash 埋め込み (https://www.youtube.com/v/SvXEllK4JUg) を iframe 埋め込み (https://www.youtube.com/embed/SvXEllK4JUg) に書き換えています。可能であれば、ページを更新して embed/object の代わりに iframe を使用してください。
    <<

    メッセージに従うと、今の A タグに書かれている、この形式の URL は古いらしいので、
    https://www.youtube.com/v/SvXEllK4JUg
    以下のように、/v/ を /embed/ に変えてみると、どうなるでしょう。
    https://www.youtube.com/embed/SvXEllK4JUg

    少なくとも、404 にはならない気がします。
  • id:weed_7777
    動きました!が…

    https://drive.google.com/open?id=0B1za9Zlbo6NiM0VIbmVSZG5ldVk

    全画面表示になってしまいます。うむむ…

    それにしてもFirefoxのエラーメッセージは親切なんですね。
  • id:weed_7777
    すいません、jsのファイルをインクルードするのを忘れていました。おかげさまで完璧に動きます。ありがとうございました!

この質問への反応(ブックマークコメント)

「あの人に答えてほしい」「この質問はあの人が答えられそう」というときに、回答リクエストを送ってみてましょう。

これ以上回答リクエストを送信することはできません。制限について

絞り込み :
はてなココの「ともだち」を表示します。
回答リクエストを送信したユーザーはいません