プログラミングの変数命名に関する質問です。

すっごくどうでもいい話なので、お気楽にご意見頂ければと。

現在作成中のプログラムで、「TD誤差の自乗平均」を保存する変数が有ります。
素直に命名すると、TD誤差="TdError"で自乗平均(のルート)="Rmse"になります。

んで、上記変数名を"tdErrorRmse"にしようと考えたんですが、これって"Error"と"e"で同じ意味がかぶっててちょっと気持ち悪いです。

かと言って、"rmsTdError"にすると、"Rmse"という一般的な名称とはかけ離れて、これもイマイチ。

という訳で、何か良い名称が有れば教えて下さい。

回答の条件
  • 1人5回まで
  • 登録:2017/06/03 18:52:31
  • 終了:2017/06/04 18:31:26

ベストアンサー

id:avocado_knight No.1

avocado_knight回答回数1ベストアンサー獲得回数12017/06/04 16:38:50

rmse_td (or rmseTd)

id:Gasyou

う~ん、シンプルなのは良いんですが、「TD誤差」と言う単語が消えちゃってるのが気になります。
引き続き、他の方の回答もお待ちしています。

2017/06/04 16:41:12

その他の回答(0件)

id:avocado_knight No.1

avocado_knight回答回数1ベストアンサー獲得回数12017/06/04 16:38:50ここでベストアンサー

rmse_td (or rmseTd)

id:Gasyou

う~ん、シンプルなのは良いんですが、「TD誤差」と言う単語が消えちゃってるのが気になります。
引き続き、他の方の回答もお待ちしています。

2017/06/04 16:41:12
id:Gasyou

変数名と、その名称にした根拠を併記して頂けると助かります。

  • id:jwrekitan
    TDerror_RMSE

    とか?。
    TDとRMSEはそれぞれ略語なので大文字表記、
    意味のまとまりをアンダースコアで区切るというだけなんですけれども。
  • id:sibazyun
    tdGosaRmse ではいかが。
    tdGosaJijoheikin でも。
  • id:Gasyou
    >>椶櫚さん
    Java言語風の命名規則にしてるので、変数はlower-camelcaseにしたいんですよ。
    なので、TDerror_RMSEだと定数とごっちゃにしそうで、ちょっと避けたいです。

    >>sibazyunさん
    すいません、英語ローマ字混じりの変数名は、受け付けづらいです。
  • id:sgo2
    英文を漁ってみると 'RMS error of (the) TD' という表現が見つかるので rmseTDで良いのでは。
  • id:Gasyou
    ググってみましたが、確かに数件ヒットしますね。
    コメントありがとうございます。
  • id:kota2009
    tde_rms

この質問への反応(ブックマークコメント)

「あの人に答えてほしい」「この質問はあの人が答えられそう」というときに、回答リクエストを送ってみてましょう。

これ以上回答リクエストを送信することはできません。制限について

絞り込み :
はてなココの「ともだち」を表示します。
回答リクエストを送信したユーザーはいません