人力検索はてな
モバイル版を表示しています。PC版はこちら
i-mobile

Mac on Linuxを起動したところ、以下のようなエラーが発生して起動しません。
どなたか対処方法を教えて下さい。
=============================================================
No mol-0.9.65 kernel modules corresponding to the running
2.4.19-0vl8smp-smp kernel were found (’startmol --list’ displays
installed version). Recompile the mol kernel modules (recommended)
or try starting MOL as root using the ’-a’ switch. The ’-a’
flag can be made default by the ’allow_kver_mismatch: yes’ setting.
=============================================================
ハード:PowerMacG4 AGP 450
OS:VineLinux2.6

●質問者: takasiym
●カテゴリ:ビジネス・経営 コンピュータ
✍キーワード:AGP as FLAG kernel Linux
○ 状態 :終了
└ 回答数 : 5/5件

▽最新の回答へ

1 ● akyora
●20ポイント

http://www.hatena.ne.jp/1080124238

Mac on Linuxを起動したところ、以下のようなエラーが発生して起動しません。 どなたか対処方法を教えて下さい。 ======================================================.. - 人力検索はてな

>Recompile the mol kernel modules (recommended)

molカーネルをリコンパイルするか、

>or try starting MOL as root using the ’-a’ switch.

-a スイッチをつけてmolを起動せよ

とありますのでその通りにされてはいかがでしょうか?

◎質問者からの返答

mol -aの結果は以下の通りです。

=============================================================

No kernel module suitable for this kernel was found. The MOL

kernel modules must be recompiled (refer to www.maconlinux.org

for instructions). The command ’startmol --list’ can be used

to display installed kernel modules.

=============================================================

startmol --listの結果は、以下の通りです。

--------------------------------------------------------------

Running kernel: 2.4.19-0vl8smp-smp

-------------------------------------------------------

Available modules:

<none>

-------------------------------------------------------

以上のことから、mol kernelをrecompileしなければならないのですが、kernel回りはサッパリやり方が分かりません。

教えて下さい。

宜しくお願いします。


2 ● Onodera
●20ポイント

http://www.vinelinux.org/ppc.html

PPC版情報

私はVineLinuxユーザーではありますが、Macは持っていないことをあらかじめお断りしておきます。

上記情報では、PowerMacG4はまだまだ対応しきれていないのかも…。

http://www.vinelinux.org/ppc/manual/index.html

ここの「Mac-On-Linux を使ってみる」にあるとおり、初期設定をしてやる必要がありそうです。

molvconfig

は実行されているでしょうか?

上記エラーを見ますと、要はkernel moduleがないということですので、インストールの際に必要なパッケージが不足していたのかも知れません。

コンソールまでは起動するのでしょうか?

起動するのであれば、エラーメッセージにある通りにrootになって

startmol -a

とやればいいのではないかと思います。

もしmolが入っていない場合、

apt-get install mol

でインストールしてください。

コンソールさえ起動しないのであれば、起動時に

single

とやってシングルモードで起動させてみてください。

その後、上記を試してみてください。

それでもだめな場合は、

1、powerbook以外の全てのパッケージをインストールすしてみる。

2、基本パッケージのみインストールし再起動。その後apt等で必要なパッケージをインストールしてみる。

など試されてみてはいかがでしょうか。特に2の場合、この時点で起動できないというのは考えにくいので、うまくいく可能性が高いです。でも、インストールできるかわかりませんが。

また、molはXを使うようですので、ビデオカードの問題かもしれませんが、これはなんともいえません。

VineSeedからすべてを持ってきてインストールしなおすのもひとつの手でしょう。

◎質問者からの返答

> 上記情報では、PowerMacG4はまだまだ対応しきれていないのかも…。

「mol」に対してですか?

あるいは「vinelinux2.6」に対してですか?

> コンソールまでは起動するのでしょうか?

??

コンソールどころかGnomeが起動しているのですが。

molvconfigを実行して設定済みです。

先程のコメントで書いた通り、

startmol -a

で失敗します。

rpm -q molの結果は、

mol-0.9.65-1vl1

rpm -q mol-kmods-0.9.65-1vl6の結果は、

mol-kmods-0.9.65-1vl6

rpm -q mol-kmods22-0.9.65-1vl6の結果は、

mol-kmods22-0.9.65-1vl6

です。

したがってmolもmolのkernel moduleも全て実装されています。

不足はありません。

> コンソールさえ起動しないのであれば、起動時に

> singleとやってシングルモードで起動させてみてください。

X-Windowsシステム上で動作するアプリケーションなのでコンソールでは動きませんよ。

> 1、powerbook以外の全てのパッケージをインストールすしてみる。

powerbookじゃない!!

PowerMacG4 AGP 450MHzって書いてるのですが!!

> 2、基本パッケージのみインストールし再起動。その後apt等で必要なパッケージをインストールしてみる。

rpmでパッケージ管理してるのでaptを使うとややこしくなりませんか?

> また、molはXを使うようですので、ビデオカードの問題かもしれませんが、これはなんともいえません。

ビデオカードの問題ならGnomeは起動しないです。

> VineSeedからすべてを持ってきてインストールしなおすのもひとつの手でしょう。

molはftpサイトのVineSeedディレクトリには入っておりません。

Vineディレクトリには入っておりますが。

引き続き回答をお待ちしております。


3 ● lethevert
●20ポイント

http://www.ring.gr.jp/pub/linux/Vine/Vine-2.6/ppc/Vine/RPMS/

「mol-kmods-0.9.65-1vl6.ppc.rpm」はインストール済みでしょうか?

カーネル(バージョン2.4.19-0vl8smp)に対応する、mol-0.9.65のカーネルモジュールがないというメッセージですので、カーネルモジュールをインストールしていない可能性があると思います。

◎質問者からの返答

そこが不思議なのです。

rpm -q mol-kmods-0.9.65-1vl6の結果は、

mol-kmods-0.9.65-1vl6

rpm -q mol-kmods22-0.9.65-1vl6の結果は、

mol-kmods22-0.9.65-1vl6

ですので、カーネルモジュールがインストールされているはずなのですが、

「mol-0.9.65のカーネルモジュールがない」というメッセージが

出てしまいます。

以前phpのmysqlモジュールをインストールした時に、

phpの本体の設定が「without-mysql」だったので、

結局ソースからビルドしなきゃいけない羽目になりましたが、

また同じ目に遭うのでしょうか(鬱。

それでしたらますますカーネルモジュールの

ビルドインストール方法が分からないとドウしようもないですね。

恐れ入りますがmolのカーネルモジュールのビルド方法を教えて下さい。

宜しくお願いします。


4 ● denn
●20ポイント

http://www.yahoo.co.jp/

Yahoo! JAPAN

(URLはダミーです、みえみえか)

はずしているかもしれませんが、マルチプロッセッサ用カーネル(smp)に対応したモジュールがない、ということではないでしょうか?

LILO で、通常のカーネルを立ち上げてみるとどうなるのでしょうか?

おそらくインストールされているモジュールは、smp 用ではなさそうです。

◎質問者からの返答

はずしてます。

でもrpm -fivhでカーネル入れて勝負挑もうかと考えてます。

が、飲みに行ったので明日にしますね。

ありがとうございます。


5 ● lethevert
●20ポイント

http://www.ring.gr.jp/pub/linux/Vine/Vine-2.6/ppc/SRPMS.main/SRP...

カーネルモジュールは、カーネルのバージョンに敏感なので、バイナリをインストールするよりも、ソースからビルドする方が確実な場合もあります。今回のケースは、それかも知れませんね。

こちらのサイトから、「mol-kmods-0.9.65-1vl6.src.rpm」をダウンロードして、ビルドしてみてはどうでしょう?

http://www.atmarkit.co.jp/flinux/rensai/linuxtips/223instsrpm.ht...

SRPMからプログラムをインストールするには

SRPMのビルドの方法は、このサイトなどを見てください。

http://www.maconlinux.net/download.html

www.maconlinux.net [4]

本家サイトから、最新版を持ってきて、パッケージをすべて置き換えるというのでもいいと思います。

本家では、本体プログラムはバイナリ配布してますが、カーネルモジュールはソースでしか配布していないようです。上と同じやり方でビルドが必要です。

◎質問者からの返答

> ソースからビルドする方が確実な場合もあります。

> 今回のケースは、それかも知れませんね。

> SRPMのビルドの方法は、このサイトなどを見てください。

SRPMのビルド方法は、ディストリビューションの差はありますが、

「rpm -ivh ××.srpm」の後、「rpm -bb ××.spec」

であることは知ってます。

ところが、カーネルモジュールのビルドインストールとなると

全く話は違ってきますます。

カーネルモジュールをSRPMからビルドインストールする方法が分かりません。

教えて下さい。

>本家サイトから、最新版を持ってきて、

> パッケージをすべて置き換えるというのでもいいと思います。

試しましたけど、libsound等5つ位のパッケージの

依存関係がらみでインストールできませんでした。

しかもgoogleりましたが、それらのppc版パッケージが

見つかりません。

--------------------------------------------

kernelのビルドインストール後、

molのkernelモジュールをインストールしたら、

キました!!

ありがとうございました。

関連質問


●質問をもっと探す●



0.人力検索はてなトップ
8.このページを友達に紹介
9.このページの先頭へ
対応機種一覧
お問い合わせ
ヘルプ/お知らせ
ログイン
無料ユーザー登録
はてなトップ