人力検索はてな
モバイル版を表示しています。PC版はこちら
i-mobile

Promise社のRAIDカード、FastTrak SX4000 liteを使用して、HDD4台でRAID5を構成しています。
このドライブを共有にして、別のPCからアクセスすると、一番上の階層にあるファイルやフォルダは見えるのですが、ファイルにアクセスしてもエラーになり、フォルダの中にも入れません。
ちなみに、アクセス出来ないのはLAN上の別のPCからだけで、ローカルPCからはアクセス可能です。
解決方法を教えて下さい。

●質問者: tamulin
●カテゴリ:ビジネス・経営 コンピュータ
✍キーワード:LAN LITE pc PROMISE RAID
○ 状態 :終了
└ 回答数 : 4/4件

▽最新の回答へ

1 ● aki73ix
●20ポイント

http://www.geocities.co.jp/SiliconValley-Cupertino/5128/500_comp...

ポートの説明

ファイル共有は135,137-139などのポートを使うのですが

http://www.microsoft.com/japan/technet/security/tools/tools/ipse...

BlasterWormがはやったときにルーターなどの設定で外部から

UDP 135

TCP 135

UDP 137

UDP 138

TCP 139

にアクセスがあった場合は遮断してしまいアクセスできないような設定になっている場合があります

ルータの設定の可能性・FireWallソフトの遮断規則などでこれらのポートを確認してみてください

ローカルからアクセスができるということなので、ルータで透過させるかフィルタの設定があると思います

http://sonobe.s5.xrea.com/knowhow/computer/closeport.html

ポートを遮断しMSブラスト等のワームを防ぐ術

参考・・・この設定をすると同じような症状になります

◎質問者からの返答

Norton Internet Security 2004を使用していますが、ファイヤーウォール機能は現在オフにしてます。

ルータは、NTT-MEのBA8000Proで、マニュアルを読むと、「WAN側からLAN側にかけてTCP/UDP 135-139番を塞いでおります。これらのポート番号のデータを透過させることは出来ません」とありますが、LAN内同士の話なので、関係ないのではないかと思うのですがどうなんでしょう?


2 ● yasukana
●20ポイント

http://www.atmarkit.co.jp/fwin2k/special/winxp_over/winxp_over_1...

特集:Windows XPとは何か? 13.ファイルのセキュリティ設定

すみません。詳しい状況がわからないので、予想になってしまいますが、

おそらく、RAID構成が原因というよりもアクセス権限の問題だと思われます。

つまり、OSがWindowsNT系だとして話しますと、共有フォルダの

「共有」タブには相手方へのアクセスを許可してあっても、

「セキュリティ」タブに相手方へのアクセスを禁止していれば

結局フォルダも開けませんし、書き込みも出来ません。

閲覧時のユーザーアカウントと、接続許可ユーザー(共有とセキュリティの両方)を

再度確認してみてください。

◎質問者からの返答

RAID構成にしているサーバのOSは、WindowsXP Professionalです。

接続しているクライアントのOSは、WindowsXP Home Edition、及び、Windows 2000 Professionalです。

質問のような現象になるのは、RAID構成にしているドライブのみで、同じマシンにRAID構成にしていないドライブもあるのですが、そちらの共有は全く問題なく読み書き出来ています。

セキュリティ設定うんぬんに関しては、イマイチよく理解出来てませんが、うまく共有出来ているドライブと、共有出来てないRAID構成のドライブでの設定は全く同じでした。


3 ● ken_na8c
●20ポイント

http://www.yahoo.co.jp/

Yahoo! JAPAN

URLはダミーです。

OSはWindows XP、2000のどちらでしょうか。

NTFSでディスクがフォーマットされていると推測

していますが、

共有時のセキュリティ設定と、そもそものディレクトリのセキュリティ設定が正しくなっているかどうか確認してみてください。

また、WindowsXPを利用している場合は、デフォルトですとファイル共有が簡易モードになっているので、フォルダオプションの設定から、簡易モードを解除し、

同様にセキュリティ設定を詳細に確認してみてください。

◎質問者からの返答

何かいろいろいじってたら直っちゃいました。

やはりRAIDは関係なく、セキュリティ設定だったようです。

ありがとうございました。


4 ● teshi
●20ポイント

http://www.isonavi.com/onlinemanu/install/detail-016.html

フォルダのセキュリティ設定

共有フォルダへのアクセス権が読み取り専用になっていると思います。

どこからでも見えて問題なければ、Everyoneををフルアクセスで追加してあげれば、解消すると思います。

◎質問者からの返答

何かいろいろいじってたら直っちゃいました。

やはりRAIDは関係なく、セキュリティ設定だったようです。

ありがとうございました。

関連質問


●質問をもっと探す●



0.人力検索はてなトップ
8.このページを友達に紹介
9.このページの先頭へ
対応機種一覧
お問い合わせ
ヘルプ/お知らせ
ログイン
無料ユーザー登録
はてなトップ