人力検索はてな
モバイル版を表示しています。PC版はこちら
i-mobile

サウンドカードの設定が普通に解りません。
誰か助けて下さい。
環境は以下の通り。
OS: Debian GNU/Linux
サウンドカード: Generic i810_audio device
uname -a の結果; Linux debian 2.4.25-1-386 #2 Wed Apr 14 19:38:08 EST 2004 i686 GNU/Linux

(Win ユーザーが適当にぐぐってサイト出すとか止めて下さいねw 少しは調べましたから)

●質問者: wslash
●カテゴリ:コンピュータ
✍キーワード:debian Debian GNU/Linux Generic GNU/Linux i686
○ 状態 :終了
└ 回答数 : 2/2件

▽最新の回答へ

1 ● kodomono-omocha
●25ポイント

http://www.tldp.org/HOWTO/Sound-HOWTO/

質問者が何を聞きたいのか普通に解りません。

誰か助けてください。

必要事項は以下の通り。

○なにをしたいのか?

○それについてどこまでわかっていてどこがわからないのか?

(こういう漠然とした質問は止めて下さいねw 少しは調べましょう)

◎質問者からの返答

取り合えず

http://www.melt.kyutech.ac.jp/~ueno/woody/alsa/

辺りを参考にALSAをアレしようとしてます。

# alsaconf でずらーっと意味解らんのがw

modinfo: snd: no module by that name found

modinfo: snd: no module by that name found

modinfo: snd: no module by that name found

modinfo: snd-opl3sa2: no module by that name found

modinfo: snd-cs4236: no module by that name found

modinfo: snd-cs4232: no module by that name found

modinfo: snd-cs4231: no module by that name found

modinfo: snd-es18xx: no module by that name found

modinfo: snd-es1688: no module by that name found

modinfo: snd-sb16: no module by that name found

modinfo: snd-sb8: no module by that name found

でー、何をしたいかというと、Skypeがやりたんですw


2 ● kodomono-omocha
●25ポイント

http://park15.wakwak.com/~unixlife/linux/de-gnome.html

DebianでのGnome & KDEのインストールと、日本語環境の構築

/etc/discover.conf

skip i810_audio ac97_codec soundcore

http://h50146.www5.hp.com/products/software/oe/linux/mainstream/...

日本HP_Linux_ハードウェア_Prosignia Desktop 325(i810E)用、Deskpro EC(i810E)用、Deskpro EN SF(i810E)用、Deskpro EXS SF(i810E)用_TurboLinux 6.0J Workstationインストールフロー

”ALSA(advanced linux sound architecture)には i810E用ドライバがありません。また動作確認当時の最新版 ALSAにもドライバがありませんでしたので OSS(open sound system) v3.9.3jで動作することを確認しています。”

http://www.turbolinux.co.jp/products/bbs/index11020.html

今回は、MP3ファイルで音楽を聞こうと思いサウンドの設定に挑戦することにしました。

サウンドの設定でALSAというのがあるというのでそれを使うことにしました。

まず、コマンドで

#alsaconf

と入力する。設定画面が表示、自動でESS-AUDIO-DEVICE-ES1688と認識されたので、あとのメニューは、OKで終了。

ドライバーモジュールの追加と確認ということで

#/etc/rc.d/init.d/slsasound start

何かエラーらしきものが・・・・とりあえず、次にすすむ。

次に、ミキサーで音量調整をしようとマルチメディア-->オーディオミキサーとメニューアイコンで実行したのですが、

no mixer found

と表示されて設定できませんでした。

ドライバーモジュールの確認として

#lsmod

コマンドをたたいたが、snd-cardモジュールが動いていないようです。

また、ハマリそうな予感。

#cat /etc/modules.conf

で設定内容を確認・・・・・何がおかしいのかわからん。

そこで、試しにサウンドブラスター16との設定の違いを見比べると・・・・・・・決定的な違いを発見。

sb16では、alias snd-card-0 snd-card-sb16

となっているのに、es1688では、

alias snd-card-0

となっていた。そこで、以下のように変更

alias snd-card-0 snd-card-es1688.o

あと他に違いがないか確認・・・・ありました。

sb16では、optionsで始まる行が2つあり、2番にはこのように書き込まれていました。

options snd-card-sb16 snd_index=0 snd_id=card_0

そこで、es1688の設定も同じように変更した。

options snd-card-es1688.o snd_index=0 snd_id=card_1

[es1688を自動認識させたときのファイルを修正]

再起動して、オーディオミキサーのアイコンをクリックすると、ミキサーが起動出来た。

スピーカーの音量調整をして、設定タグを開き「起動時に以前のミキサーレベルへ復帰」にチェック。

次に、ディスクトップ設定-->マルチメディア-->サウンドのアイコンで設定画面を開き、

設定タグで「起動時に音サーバーを使う」にチェック。

root以外でも、サウンドを使用可能にする為、

#snddevices

とコマンドを打ち込めばOK。

でも、音が鳴るようになったのはよかったんだけど、mp3ファイルってwin98-pcの中に置かれてたんだっけ。

やっぱり、SMBサーバーと立てないとダメかな。

◎質問者からの返答

alsaconf が通れば苦労しないです。

関連質問


●質問をもっと探す●



0.人力検索はてなトップ
8.このページを友達に紹介
9.このページの先頭へ
対応機種一覧
お問い合わせ
ヘルプ/お知らせ
ログイン
無料ユーザー登録
はてなトップ