人力検索はてな
モバイル版を表示しています。PC版はこちら
i-mobile

PHPの質問です。
サイト全体をPHPで構築しているのですが、アクセスするタイミングによって
Parse error: parse error, unexpected ’}’〜
のエラーが出てしまうことがあります。
現象としては、
http://www.hatena.ne.jp/1106014137
と全く同じです。ただ私のPHPのバージョンはPHP5.0.3で、スクリプトは全てEUC-JPで書いています。
1つのページでこのエラーが出ると、他のページでも同様にしばらくエラーになります。
このような現象が起こる原因や、回避策がありましたら教えて下さい。

●質問者: wintarsnow
●カテゴリ:ウェブ制作
✍キーワード:EUC-JP PHP アクセス エラー サイト
○ 状態 :終了
└ 回答数 : 1/1件

▽最新の回答へ

1 ● bmkage
●50ポイント

http://oshiete1.goo.ne.jp/kotaeru.php3?q=1261486

教えて!goo たまにエラーになる現象

参考URLの方でもいろいろ議論になっているようですが

お使いのWebサーバーはApache2でしょうか?


私も今まで何度かApache+PHPの環境で作業をしてますが

Apache1.3.33のときはエラーが出なかったけれど、

Apache2になってからは同様のエラーになるのを

見たことがあります。


原因としては、PHP5が不安定なのか、

Apacheとの組み合わせの問題か、

php.iniの設定なのか・・・

はっきりとした原因は分かりかねるようです。。。


(参考URLの中の話で、PHP5.0.3→PHP5.0.4にしたら

調子がよくなったという方がいますね。)


以上の話が参考になるといいのですが。

◎質問者からの返答

回答ありがとうございます!

論議になっている現象だったのですね。

URLも参考になりました。

ちなみにApacheのバージョンは1.3.27です。

レンタルサーバなので、とりあえずPHPのバージョンが上がるまで様子を見るしか無さそうですね…。

ありがとうございました!

関連質問


●質問をもっと探す●



0.人力検索はてなトップ
8.このページを友達に紹介
9.このページの先頭へ
対応機種一覧
お問い合わせ
ヘルプ/お知らせ
ログイン
無料ユーザー登録
はてなトップ