人力検索はてな
モバイル版を表示しています。PC版はこちら
i-mobile

WEBサーバの中で 複数の dllhost.exe の内のひとつが OS起動後しばらくするとCPU使用率が100%になってしまい非常に困っています。


環境
OS: Windows2000Server(SP4)
IIS: 5.0

状況
1.ウィルスではない(トレンドマイクロのオンラインウイルスチェックを実施済み)
2.同一処理を行っている負荷分散用の別サーバでも発生している。したがって、現在は交互に再起動して運用中。
3.IISを再起動すると、とりあえず直る

困ってます。
対処方法をご存知の方、何卒ご教授いただけますようお願いします。

●質問者: BAZZ
●カテゴリ:コンピュータ
✍キーワード:exe OS ひとつ ウィルス ウイルス
○ 状態 :終了
└ 回答数 : 2/2件

▽最新の回答へ

1 ● tsubasa
●30ポイント

http://support.microsoft.com/

Microsoft Help and Support

ご質問の再現条件が漠然としているようですので、差し当たっては調査のため「パフォーマンス モニタで監視してみる」ぐらいしか思いつきません。文書番号 253603 で検索してください。『[IIS] HOWTO: Internet Information Services での CPU 使用率が高い ”ハング” 状態のトラブルシューティング』が見つかります。

http://www.microsoft.com/japan/technet/prodtechnol/windows2000se...

Microsoft TechNet: Internet Information Services 5.0 ‐ 展開

Microsoft:『Windows 2000 Web アプリケーションのデバッグ』。「CPU 使用率が 100% に達する問題」セクションを参照してください。

http://www.bea.hi-ho.ne.jp/byoko/bnewslog29.html

Baba Centerfolds BNEWS LOG 29

お節介かも知れませんが:

よそ(OKWeb, 教えて!goo)でも質問されているようですが、一般的にマルチポストはあまり歓迎されませんよ。

現象の再現環境において、BAZZ さんが開発された DLL ファイルなり他社製品なりを使用されているのでしたら、そのことも書かなければ適切な回答が寄せられないと思います。

◎質問者からの返答

問題は dllhost.exe が CPU 100% となることで、冒頭の質問に書いてあります。

この質問は、よそ(goo)とは似ていますが、ちょっと条件が異なります。なので、マルチポストではありません。詳細な条件を提示することができない事情のため申し訳ございません。最後のリンクが気になって見ています。ご回答ありがとうございます。


2 ● medical_blog
●20ポイント

http://www.atmarkit.co.jp/fwin2k/win2ktips/384mdactool/mdactool....

@IT:Windows TIPS -- Tips:MDACのバージョン調査ツールを利用する

以前同様なことがうちでもありました。

その時はMDACのバージョンを上げたら治りました。

間違っていたらポイントいらないです。

◎質問者からの返答

ありがとうございます。

関連質問


●質問をもっと探す●



0.人力検索はてなトップ
8.このページを友達に紹介
9.このページの先頭へ
対応機種一覧
お問い合わせ
ヘルプ/お知らせ
ログイン
無料ユーザー登録
はてなトップ