人力検索はてな
モバイル版を表示しています。PC版はこちら
i-mobile

apacheの起動時にphp4_module is already lodedというエラーが出ます。httpd.confにはLoadModule php4_moduleは一行しかないのですが、他に確認するべき所はありますか?

●質問者: am0200
●カテゴリ:コンピュータ
✍キーワード:Apache httpd エラー
○ 状態 :終了
└ 回答数 : 2/2件

▽最新の回答へ

1 ● Marin_MTB
●20ポイント

http://www.hatena.ne.jp/

はてな

AddModuleがダブっていませんか?

httpd -lしてすでにmod_php4.so(Windowsはdll)が組み込まれている、ということはありませんか?

◎質問者からの返答

httpd -lではmod_php4.soは組み込まれていないようです。書き忘れましたがApache2.0系なのでAddModuleはありません。


2 ● JULY
●120ポイント

http://httpd.apache.org/docs/1.3/mod/core.html#include

Apache Core Features

httpd.conf 中に Include ディレクティブが指定されていませんか?


Vine のデフォルトでは「Include conf.d/*.conf」といった記述があって、

/etc/httpd/conf.d 以下にモジュールごとの設定内容が記述されている

ファイルがあります。

◎質問者からの返答

conf.d/にphp.confがありました。この中にもLoadModule指定がありましたのでhttpd.confから削除したら解決しました。有難うございます。

関連質問


●質問をもっと探す●



0.人力検索はてなトップ
8.このページを友達に紹介
9.このページの先頭へ
対応機種一覧
お問い合わせ
ヘルプ/お知らせ
ログイン
無料ユーザー登録
はてなトップ