人力検索はてな
モバイル版を表示しています。PC版はこちら
i-mobile

Greasemonkeyがおもしろそうだなぁと思っているのですが使い方がわからないといいますか、反応してないようなのです。
3つくらいスクリプトを入れてみたのですが反応していないようです。
firefoxの右下にはサルのマークもでてますし、メニューの「ツール」にも「Install User Script」とか「Manage User Scripts」は表示されています。
スクリプトを登録したときに成功のダイアログもでます。
何が原因なのかネットで検索してもよくわかりません。
詳しい方、ぜひ教えていただけたらと思います。
ちなみにいれたスクリプトはmixi関係のです。
環境はmac10.3.9、Firefox1.0.6、Greasemonkey0.3.5です。

●質問者: poppycock
●カテゴリ:コンピュータ
✍キーワード:firefox Greasemonkey mixi SCRIPT USER
○ 状態 :終了
└ 回答数 : 1/1件

▽最新の回答へ

1 ● sanbo-n
●40ポイント

http://japan.cnet.com/news/sec/story/0,2000050480,20085595,00.ht...

Firefoxのアドオン「Greasemonkey」にセキュリティ上の欠陥 - CNET Japan

Greasemonkeyは前のバージョンにセキュリティの問題があって、現バージョンになりました。

しかし、そのセキュリティの問題を回避するために、URLの文中に


>バージョン0.3.5にはGreasemonkeyをHTMLよりも強力にするために考えられた「GM*」APIがなく、その結果これらのAPIに依存するスクリプトはバージョン0.3.5では動かなくなるとしている。ある開発者は「Greasemonkey 0.3.5はGreasemonkeyの去勢バージョンだ」と同ブログに書き込んでいる。


とあるように

前のバージョンよりも機能的に制限されている部分があるようです。

スクリプトのこととか詳しいことはわからないのですが、多分その辺が原因ではないかと思われます。(はてなグリースモンキーでも、グリースモンキーのバージョンアップによって使えなくなったものなどがありました。)

スクリプト作成者の方にスクリプトが現在のグリースモンキーのバージョンでも正常に動くのか、スクリプトの新バージョンが出ていないか、などをメールなどで直接聞かれてみることをオススメします。

◎質問者からの返答

ちょっぴりそうなのかもと思ってました。

きっとgreasemonkeyが反応してないんじゃなくってスクリプトがバージョンに対応してないんですよね。

危険かなぁと思いながらもベータ版を入れてみたらできました。

ありがとうございました。

関連質問


●質問をもっと探す●



0.人力検索はてなトップ
8.このページを友達に紹介
9.このページの先頭へ
対応機種一覧
お問い合わせ
ヘルプ/お知らせ
ログイン
無料ユーザー登録
はてなトップ