人力検索はてな
モバイル版を表示しています。PC版はこちら
i-mobile

linuxにすでにインストールされているPHP4をPHP5にインストールしなおしたいのですが、方法をお教えください。まだlinuxでコンパイル等をやったことがなく、アプリにインストール
も未経験です

●質問者: masa14149
●カテゴリ:コンピュータ
✍キーワード:Linux アプリ インストール コンパイル 経験
○ 状態 :終了
└ 回答数 : 2/2件

▽最新の回答へ

1 ● suketohdara
●20ポイント

http://www.dolphy.gr.jp/webap/env/php-install-fc3.html

Dolphy PHPインストール FC3

よろしければ、お使いのLinuxのディストリビューションをお教えください。ソースコンパイルを行わなくても、多くのディストリビューションでは簡単にインストール/アップデートが行えるパッケージ管理機能がついていますが、ディストリビューションによってパッケージの管理方法が異なります。


URLは、とりあえずメジャーなFedora Coreの場合のパッケージ管理コマンド、「yum」でのアップデートに関して書かれています。


yum update php


とすれば、基本的にオッケーです。


2 ● satoruk
●30ポイント

http://www.php.net/manual/ja/

PHP: PHP マニュアル - Manual

手順から言うと、ダウンロードして展開したあと

中に含まれる「INSTALL」テキストファイルなどを見て

コンパイルしインストールをします。


その後、httpd.confを以下のように編集します


[削除] LoadModule php4_module libexec/libphp4.so

[追加] LoadModule php5_module libexec/libphp5.so


[削除] AddModule mod_php4.c

[追加] AddModule mod_php5.c


念のため↓の設定があるか確認してください。

AddType application/x-httpd-php .php .phtml


設定後、Apacheを再起動すれば反映されます。


重要なのは、モジュールを切り替えることです。

◎質問者からの返答

ありがとうございました

参考になりました

関連質問


●質問をもっと探す●



0.人力検索はてなトップ
8.このページを友達に紹介
9.このページの先頭へ
対応機種一覧
お問い合わせ
ヘルプ/お知らせ
ログイン
無料ユーザー登録
はてなトップ