人力検索はてな
モバイル版を表示しています。PC版はこちら
i-mobile

最近報告されたPHPの脆弱性について教えて下さい。register_globals=offとなっていれば、とりあえず問題はないのでしょうか?PHP4.3.7を現在運用しています。

●質問者: loy
●カテゴリ:コンピュータ
✍キーワード:PHP register_globals 現在 脆弱性 運用
○ 状態 :終了
└ 回答数 : 2/2件

▽最新の回答へ

1 ● gogoakkey
●25ポイント

http://php.s3.to/off.txt

これを見る限り現状は問題ないようです。

http://www.seya.org/mt/archives/2004/02/03_php_register_globals....

SEYA.ORG: PHPのregister_globalsではまりました

追加内容

http://blog.ohgaki.net/index.php/yohgaki/2005/11/03/phpa_rc_fei_...

yohgaki's blog - PHPの現行リリースに重大な脆弱性(PHP4.4.0以下、PHP5.0.5以下) - その2

ここの冒頭に記載がありました。

http://www.php.net/ChangeLog-4.php#4.4.1

PHP: PHP 4 ChangeLog

本家のChangeLogを参照しても目立った記載はありませんでした。

英語は苦手ですが・・・。


2 ● tomo12345
●25ポイント

http://blog.ohgaki.net/index.php/yohgaki/2005/11/09/phpa_rc_fei_...

yohgaki's blog - PHPの現行リリースに重大な脆弱性(PHP4.4.0以下、PHP5.0.5以下) - まとめ

このページをを見る限りregister_globals=offになっていれば大きな問題は無いようです。

関連質問


●質問をもっと探す●



0.人力検索はてなトップ
8.このページを友達に紹介
9.このページの先頭へ
対応機種一覧
お問い合わせ
ヘルプ/お知らせ
ログイン
無料ユーザー登録
はてなトップ