人力検索はてな
モバイル版を表示しています。PC版はこちら
i-mobile

cygwin上でapacheとpostgresqlを動かしています。
perlのCGIからだとuse Pg;の部分で「Can’t locate Pg.pm in @INC (@INC contains: /usr/lib/perl5/5.8/cygwin /usr/lib/perl5/5.8 /usr/lib/perl5/site_perl/5.8/cygwin /usr/lib/perl5/site_perl/5.8 /usr/lib/perl5/site_perl/5.8 /usr/lib/perl5/vendor_perl/5.8/cygwin /usr/lib/perl5/vendor_perl/5.8 /usr/lib/perl5/vendor_perl/5.8 .) at /var/www/cgi-bin/test/test1.cgi line 2.BEGIN failed--compilation aborted at /var/www/cgi-bin/test/test1.cgi line 2.」となり、
phpからだと「Fatal error: Call to undefined function: pg_connect()」
となってしまいます。
解決策ご存知の方いましたら教えてください。
Configure Commandは
’./configure’ ’--with-apxs=/usr/sbin/apxs’ ’--without-mysql’ ’--enable-mbstring’
となっています。

●質問者: double2you
●カテゴリ:コンピュータ
✍キーワード:Apache AT BEGIN CGI Command
○ 状態 :終了
└ 回答数 : 2/2件

▽最新の回答へ

1 ● 浅倉卓司
●40ポイント

http://search.cpan.org/~mergl/pgsql_perl5-1.9.0/Pg.pm

Pg - Perl5 extension for PostgreSQL - search.cpan.org

Pgモジュールをインストールしましょう。


cpanツールを起動して、install Pgとすれば入ると思います。


#もっとも、個人的にはDBI/DBD::Pgを使ったほうが良いと思いますけれど。

◎質問者からの返答

ありがとうございます。CPANは動くのですが、install pgでLWP not availableです。orz


2 ● battan
●10ポイント

http://www.atmarkit.co.jp/flinux/rensai/postgres03/postgres03.ht...

PostgreSQLをプログラムで操作する

「PostgreSQLをプログラムで操作する」

下の方にPHPもあります。

PostgreSQLを操作するためのモジュールがないためのエラーですので、Perl、PHPをモジュール設定をしての再インストールが必要になります。


余談ですが、Windows上で動作するPostgreSQLがでてますので、Windows版のApache、ActivePerl、PHPにて環境を構築した方が楽かもしれません。もっともPosgreのバージョンが上がってしまうのでテスト環境としてご使用であれば本番環境とバージョンを合わせる場合は不可ですけど・・・

◎質問者からの返答

実はここの確認スクリプトで動作確認しようと思ったら動かなくて質問させていただいた次第なのです。

CPANが無事動きましたので一旦解決とさせていただきます。ありがとございました。

関連質問


●質問をもっと探す●



0.人力検索はてなトップ
8.このページを友達に紹介
9.このページの先頭へ
対応機種一覧
お問い合わせ
ヘルプ/お知らせ
ログイン
無料ユーザー登録
はてなトップ