人力検索はてな
モバイル版を表示しています。PC版はこちら
i-mobile

急いでいます! PostgreSQL 8.1.1に脆弱性があるとのことで8.1.2がリリースされました。
最近運用が始まったRed Hat Linuxサーバで8.1.1が稼動していますが、
8.1.2へのバージョンアップの方法を教えて下さい。
PostgreSQL自体はソースからコンパイルしてインストールしました。

●質問者: kamiochiai
●カテゴリ:ウェブ制作
✍キーワード:Linux postgreSQL Red Hat インストール コンパイル
○ 状態 :終了
└ 回答数 : 1/1件

▽最新の回答へ

1 ● くまっぷす
●150ポイント

http://www.postgresql.jp/document/pg803doc/html/install-upgradin...

”PostgreSQL自体はソースからコンパイルしてインストールしました。”とのことですが、これは8.1.1を?ですよね。

一応参考URLに移行手順をあげていたところを提示しますが、8.1.1から8.1.2についてはデータ構造に変更はないので単にpostgresql8.1.2をビルドすればそのまま移行できます(8.1.2のHISTORYにも” A dump/restore is not required for those running 8.1.X. ”とあります。ただし、その後にテキストデータのカラムでREINDEXを行う必要はあるかも、と書いてありますが)。

つまりソースのINSTALLにあるadduser postgres以下を”やらない”だけです。

心配であればURL手順にあるようにバックアップを取っておけばいいでしょう。(バックアップは定期的に取るべきなのでいい機会かも)

http://ml.postgresql.jp/pipermail/pgsql-jp/2005-July/019325.html

[pgsql-jp: 35765] Re: データのアップグレードの方法

◎質問者からの返答

「データ構造に変更がない」ということで、安心です。

ありがとうございます。

関連質問


●質問をもっと探す●



0.人力検索はてなトップ
8.このページを友達に紹介
9.このページの先頭へ
対応機種一覧
お問い合わせ
ヘルプ/お知らせ
ログイン
無料ユーザー登録
はてなトップ