人力検索はてな
モバイル版を表示しています。PC版はこちら
i-mobile

mod_layout-3.2をmake使用とするとどうしてもエラーが出てインストールが出来ません。

Apache2.0.40-21.20.1
SSI使用可
CGIディレクトリ別で使用可
PHP使用可。

・Apache モジュール設定
ルートディレクトリ /etc/httpd
httpdの実行可能パス /usr/sbin/httpd
apachectl /usr/sbin/apachectl
apache起動 /etc/rc.d/init.d/httpd

Makefileの中を
APXS=/usr/sbin/apsx
APACHECTL=/etc/rc.d/init.d/httpd/
APSXを$(APXS)と置き換えmakeしたのですが
初期化子の要素が定数ではありませんや初期化は不完全ですとでてmake出来ません…
何が原因かわかりませんでしょうか?
よろしくお願いします。

●質問者: zenval
●カテゴリ:ウェブ制作
✍キーワード:2.0 Apache CGI ETC httpd
○ 状態 :終了
└ 回答数 : 1/1件

▽最新の回答へ

1 ● kimizu
●150ポイント

http://yaguma.com/Server/mod_layout.html

Yaguma's HP - mod_layout

まず、mod_layout3.xはApache2系で使用できません。

mod_layout4.x系を使用するか、Apache1系を使用してください。


エラーメッセージは、訳さなくても結構ですので、出力されたものを

省略せずに全て記述したほうがいいです。行数や変数名、

その他の情報も出てますので。


はてなに記述するのは、長くなりすぎると思いますので、

例えば、はてなダイアリーを作成し、日記として書き込むと

良いと思いますよ。


ところで、APSXを$(APXS)にする必要ありますか?

◎質問者からの返答

こちらの質問への回答は改善されましたのでここで終了すべきですね^^;

ありがとうございましたm(_ _)m

関連質問


●質問をもっと探す●



0.人力検索はてなトップ
8.このページを友達に紹介
9.このページの先頭へ
対応機種一覧
お問い合わせ
ヘルプ/お知らせ
ログイン
無料ユーザー登録
はてなトップ