人力検索はてな
モバイル版を表示しています。PC版はこちら
i-mobile

Movabel Type3.2jaの件です。WinXPにて自宅サーバを構築しております。ActivePerl5.8.8とAnWeb/1.41g 、そしてMysql5.0を使用しておりますが、mt-check.cgiで確認すると、「Movable Typeのシステム・チェックは、無事に完了しました」とのメッセージが現れれました。が、今度は「データベースを初期化中・・・」インストールを開始しますという表示が出て、止まっているようです。そして「実行しましたが、ページでエラーが発生しました」とIE画面左端に表示され、何も動きません。どのような対処をして原因を探ればよいでしょうか?

●質問者: Sono
●カテゴリ:コンピュータ インターネット
✍キーワード:CGI IE Movable Type MT WinXP
○ 状態 :終了
└ 回答数 : 4/4件

▽最新の回答へ

1 ● sudayosiaki
●10ポイント

http://lolipop.jp/?mode=manual&state=blog&state2=mt_2&PHPSESSID=...

mt-check.cgiで確認するのではなく、『 インストールを続行 』ボタンを押すそうです。

設定が正常に完了している場合、自動的にインストールが行われます。

『 インストールが完了しました。 』 という文章が表示されれば、完了です。

そうでないエラーが出た場合は、もう一度、パーミッションの設定やファイル名または 『 mt-config.cgi 』 の設定を見直してみてください。

◎質問者からの返答

このURLはレンタルサーバでの説明ですね( ̄◇ ̄;)

基本確認はmt-check.cgiでOKがでなければ、「インストールを続行」のボタンを押せませんよね。正しいmt-config.cgi の設定、パーミッションの設定が分かるご回答をお願いできますか?


2 ● 最低人間
●20ポイント

http://q.hatena.ne.jp/1146545667

の二つ目で回答してあったり。

◎質問者からの返答

>mt.cfgのデータベース設定と、MySQL側が一致

>していない事が考えられます。

>Database

>DBUser

>DBPassword

>DBHost

>以上4つの項目がきちんと設定できているか、ま

>たMySQL側でそのDatabase名とDBUser名は存在

>するか、が問題となります。

>存在しない場合は、データベースを新規作成す

>る必要があります。

>http://rebecca.ac/milano/mt3/

>http://www.woodensoldier.info/computer/blog-install.htm

以上の項目が怪しいようですね。上記4項目は

なんども見直しました。sql側ですが

ちなみにデータベース名はcreateでmtとし

ユーザーはrootでそのままにしております。

sql側でuserの追加はできていません。というより・・・sqlはあまり詳しくないのでuser追加の方法がわかりません。


3 ● zesu
●20ポイント

mt-check.cgiでの確認は、悪魔でサーバーサイドに必要なモジュール等がインストールされているかのチェックです。なので、OKが出たからといって、mt-config.cgiの設定が確実に合っているとは限りません。

データベースの初期化で止まったあたりから、再度作成したデータベースユーザーやパスワードを確認してみて下さい。恐らくそこが原因かと思います。MySQLを使用されているようなので、mt-config.cgiの35行目?39行目の設定という事になります。

時々忘れる方がいらっしゃるようですが、行頭の「#」は削除しないとコメントアウトされてしまうため、確認してみて下さい。

インストールとは関係無いのですが、MT3.2はMySQL5.0以降のサーバーだと文字化けしてしまうようです。インストール後↓を参考にしてみるといいかもしれないです。

http://yuzumoni.s56.xrea.com/archives/5/52/


4 ● tenshiks
●40ポイント

とりあえずコマンドラインからDBへの接続を確認する。

http://www.bayashi.net/archives/entry/2005/000167.html

mt-config.cgiへそのUser名、pass等を設定する。

備考ですが、私も設定不備でDBの辺りで止まり一度インストールが止まり、その後きちんと設定した後で再試行しても正常にインストールが続行できなかった経験があります。

変な情報が書き込まれているのか、一度既存のものを消し、新しくプログラムをDLし直して再設定したら正常に動きました。

詰まったときは最初からという事で一応。

関連質問


●質問をもっと探す●



0.人力検索はてなトップ
8.このページを友達に紹介
9.このページの先頭へ
対応機種一覧
お問い合わせ
ヘルプ/お知らせ
ログイン
無料ユーザー登録
はてなトップ