人力検索はてな
モバイル版を表示しています。PC版はこちら
i-mobile

xreaでPHPを使用していてsafe modeがらみのエラーが出てきて困っています。

モジュールとしてではなく、CGIとしてなら、safe modeがoffらしいので、モジュール版のPHPに変更をいけずに、htaccessなどで、cgi版として動作させることはできないのでしょうか?

●質問者: iiiiiiiii
●カテゴリ:インターネット ウェブ制作
✍キーワード:CGI PHP XREA エラー モジュール
○ 状態 :終了
└ 回答数 : 2/2件

▽最新の回答へ

1 ● b-wind
●30ポイント

http://www.xrea.com/?action=faq#8

CGIとして(SafeModeなし)でご利用可能頂く場合は、先頭行に#/usr/local/bin/phpを入れ、拡張子を.cgiにして実行して下さい。

.php 拡張子のまま CGI として動かす事は出来ますが、xrea で可能かどうかは分かりません。

ただし、先頭行の変更は必須です。

http://httpd.apache.org/docs/2.0/ja/mod/mod_mime.html#addhandler

AddHandler cgi-script .cgi
◎質問者からの返答

やはり先頭行は必須ですか。


2 ● shun262
●40ポイント ベストアンサー

こちらにありますね。

http://sb.xrea.com/showthread.php?t=10744

.htaccessに

AddHandler application/x-httpd-phpcgi .php

と、書けばそのディレクトリ内の*.phpはCGIモードで動作するようです。

しかし、この場合はCGIとして動作させるのでPHPの特徴である「快適」さが失われます。負荷もある程度かかるので、できるならばsafemodeでも動くようなPHPコードにするほうがよいでしょう。

◎質問者からの返答

あら、すごい。これを試してみます。

関連質問


●質問をもっと探す●



0.人力検索はてなトップ
8.このページを友達に紹介
9.このページの先頭へ
対応機種一覧
お問い合わせ
ヘルプ/お知らせ
ログイン
無料ユーザー登録
はてなトップ