人力検索はてな
モバイル版を表示しています。PC版はこちら
i-mobile

Image Magic に関する質問です。

サーバー会社に聞くとインストールされていると
いわれたのですが、うまく作動しません。

以下のエラーメッセージが出ます。

Software error:
Can't load '/usr/lib/perl5/site_perl/5.8.7/i686-linux/auto/Image/Magick/Magick.so' for module Image::Magick: libMagick.so.10: cannot open shared object file: No such file or directory at /usr/lib/perl5/5.8.7/i686-linux/DynaLoader.pm line 230.
at convert.cgi line 39
Compilation failed in require at convert.cgi line 39.
BEGIN failed--compilation aborted at convert.cgi line 39.

何かモジュールが足りないというような感じなのですが、原因はわかりますでしょうか。

よろしくお願いいたします。

●質問者: choppar
●カテゴリ:コンピュータ ウェブ制作
✍キーワード:AT BEGIN CGI i686 LIB
○ 状態 :終了
└ 回答数 : 2/2件

▽最新の回答へ

1 ● b-wind
●35ポイント

'/usr/lib/perl5/site_perl/5.8.7/i686-linux/auto/Image/Magick/Magick.so' というライブラリが読み込めないというエラーです。

可能性として考えられるのは、Image::Magick モジュールは XS を使用しているのでインストールにライブラリをコンパイルする必要があります。

インストールが不完全(.pm ファイルだけ子手動でコピーとか)という印象を受けます。

◎質問者からの返答

回答有難うございました。


2 ● kentaro543g
●35ポイント

ImageMagickをPerlからお使いになりたいのでしょうか? その場合は、PerlMagickがインターフェースするのが一般的です。PerlMagickがインストールされてないようにも見えるのですが、いかがですか?

Windows用の説明ですが、参考にしてみてください。

http://www.ss.iij4u.or.jp/~somali/web/_imagemagick.html

◎質問者からの返答

回答有難うございました。

関連質問


●質問をもっと探す●



0.人力検索はてなトップ
8.このページを友達に紹介
9.このページの先頭へ
対応機種一覧
お問い合わせ
ヘルプ/お知らせ
ログイン
無料ユーザー登録
はてなトップ