人力検索はてな
モバイル版を表示しています。PC版はこちら
i-mobile

PHPを学習しています。
現在のバージョンが5.2ですが、テキストと食い違う点が多くなってきました。
そこで他のバージョンの5.10または5.11を入手したいと思っています。
どこで入手できるでしょうか。

一応現在直面している問題点を挙げると、
5.2ではPDO関数を利用することができますがPEARのインストールがうまくいきません。
古いタイプの5.01ではPEARのインストールはできますがPDO.dllなどが導入できません。

●質問者: plugbot
●カテゴリ:コンピュータ ウェブ制作
✍キーワード:DLL Pear PHP インストール タイプ
○ 状態 :終了
└ 回答数 : 3/3件

▽最新の回答へ

1 ● guesthouse
●20ポイント

「PHP5.2.0 には同梱される go-pear.bat スクリプトに不都合があります」

http://blog.goo.ne.jp/g_suzu/e/cf4dde22ce1d9950a349315bbea08800

ということで、リンク先にあるような手順でPEARを設定すれば、PHP5.2.0のままでいけると思います。

◎質問者からの返答

書き間違えました。pearのインストールはできて(go-pear.batとpearフォルダ内のスクリプト変更)ライブラリのインストールができないのです。

could not open xxx for writing

とエラーが出てとまったままです。

どちらにしても原因がわからないのでまずはテキストのバージョンをあわせて学習を進めようと考えています。


2 ● kronecker
●35ポイント

http://jp.php.net/releases/index.php

PHPについては全く知らないけどここって公式サイトじゃないの?

5.10とか5.11ってバージョンはないけど…

もし5.1.0や5.1.1の間違いなら上記サイトで入手できます。

◎質問者からの返答

ここですね。ありがとうございます。


3 ● b-wind
●25ポイント

http://jp.php.net/releases/index.php

こちらに過去のバージョンの一覧があります。

お好きなものをどうぞ。

関連質問


●質問をもっと探す●



0.人力検索はてなトップ
8.このページを友達に紹介
9.このページの先頭へ
対応機種一覧
お問い合わせ
ヘルプ/お知らせ
ログイン
無料ユーザー登録
はてなトップ