人力検索はてな
モバイル版を表示しています。PC版はこちら
i-mobile

WEBの開発をおこなっておりますが、Netscape4.7を使用されているお客様より画面がずれて表示されると問合せがあったのですが、Netscape4.7に対応すると工数が非常にかかるため、うまく断る方法がないでしょうか。ちなみに、Netscape4.7はすでに製品としてサポートされてない等の説明をしたのですが、納得できる回答をお願いします。

よろしくお願い致します。


●質問者: jack0218
●カテゴリ:インターネット ウェブ制作
✍キーワード:Web お客様 かるた サポート 対応
○ 状態 :終了
└ 回答数 : 4/4件

▽最新の回答へ

1 ● hallo21
●23ポイント

netscape4.7がもう使われてない、サポート外だといっても、それを使っている相手は納得しないでしょう。ブラウザ標準の規格がかわったという言い方にした方がいいと思います。

http://end


2 ● MERCY
●23ポイント

http://www.w3counter.com/globalstats.php

単純に、工数が掛かります、で良いんではないですかね?

0.5%以下のユーザーの為にXXXXXX円掛かります、かけますか?

まぁ、掛けるといわれたら、それはお仕事なわけですし

添付URLはブラウザシェアです。


3 ● Yota
●22ポイント

例えば、動作確認ブラウザは下記のとおりです。

・Internet Explorer 6.0 for Windows

・Internet Explorer 6.0 SP1 for Windows

・Internet Explorer 6.0 SP2 for Windows

・Netscape Communicator 4.78 for Windows

とサイトのトップでうたっておけばどうでしょう。

でも今の問題ですが、仕方ないのでnavigator.userAgentでその古典ブラウザを識別して、styleオブジェクトを修正するというのでどうでしょう。

CSSの実装は例えばFFとIEでもだいぶ違うところがあるので、あまりずれるときは、共通のstyleで対応できないときもあります。

参考

http://www.openspc2.org/JavaScript/reference4/index.html


4 ● popattack
●22ポイント ベストアンサー

Netscape4.7を今時好きこのんで使っているのは取引先との関係があるんではないでしょうか?トヨタ自動車の車内標準ブラウザはNetscape4.7です。人によってはIE使ってますけどね。今年度中にWindows Vistaに移行していく予定みたいなので、当然Netscape4.7は標準から消え去ります。ということで、大きい会社でもNetscape4.7から移行しようとしているのだから、Vista誕生と共にブラウザも変えてみてはどげんですか?セキュリティホールからハッキングされるかもしれないので、それも怖いですよと脅すとかどげんですか?

http://q.hatena.ne.jp/answer

関連質問


●質問をもっと探す●



0.人力検索はてなトップ
8.このページを友達に紹介
9.このページの先頭へ
対応機種一覧
お問い合わせ
ヘルプ/お知らせ
ログイン
無料ユーザー登録
はてなトップ