人力検索はてな
モバイル版を表示しています。PC版はこちら
i-mobile

ASP.NET2.0 で作ったaspxのページはIE,Firefoxなど各ブラウザのバージョンいくつ以上ならば表示可能なのでしょうか。

●質問者: gdswwr
●カテゴリ:コンピュータ
✍キーワード:2.0 ASP.NET firefox IE バージョン
○ 状態 :終了
└ 回答数 : 3/3件

▽最新の回答へ

1 ● KUROX
●27ポイント

情報ないですね・・・。

HTML 4.0準拠しているバージョンからですかね。

http://japan.internet.com/developer/20051025/26.html


2 ● minkpa
●27ポイント

とりあえずIE6.0は表示可能でした。

http://q.hatena.ne.jp/1186024820


3 ● kn1967
●26ポイント

ASP.NETでは

IE5.5以降が上位ブラウザ

IE5.01までと、IE以外のブラウザは下位ブラウザ

JSP から ASP.NET への移行ガイド : 複数ブラウザのサポート


ASP.NET 2.0でも

IE5.5以降が上位ブラウザ

それ以外全て下位ブラウザ

と認識するのは同じ(ASP.NETの上位互換)


ASP.NETの利点は.NET Frameworksを使う事によってクライアント環境の違いを吸収することにあるので

aspxファイル内に記述したコードがリッチクライアントによる動作を期待してのものであるならば

上位ブラウザとして認識されるもの(IEの5.5以降)が必要となります。

関連質問


●質問をもっと探す●



0.人力検索はてなトップ
8.このページを友達に紹介
9.このページの先頭へ
対応機種一覧
お問い合わせ
ヘルプ/お知らせ
ログイン
無料ユーザー登録
はてなトップ