人力検索はてな
モバイル版を表示しています。PC版はこちら
i-mobile

PHP5.1.6をyumコマンドでインストールした
後に。PHP5.2.4をmake installして
/etc/httpd/conf/httpd.confに
AddType application/x-httpd-php .php
と記述したのですが、ブラウザ上で
phpinfoで確認をするとまだ5.1.6のままです。
設定を有効にするにはどうしたらいいでしょうか?
OSはcentOS5になります。


●質問者: hopefully
●カテゴリ:就職・転職 ウェブ制作
✍キーワード:application ETC httpd make OS
○ 状態 :終了
└ 回答数 : 1/1件

▽最新の回答へ

1 ● wnagata
●60ポイント

LoadModule でPHPのモジュールを読み込むときに、5.1.6のモジュールが読み込まれています。PHP5.2.4のlibphp5.soを読み込むように、LoadModule をフルパスで設定するとよいでしょう。

http://www.atmarkit.co.jp/flinux/rensai/apache2_03/apache03a.htm...

◎質問者からの返答

PHP5.2.4のlibphp5.soがみつからないのですが?

もしかしたらインストールミスですかね?

find / -name libphp5.so

/usr/lib/httpd/modules/libphp5.so

しかないのですが?

関連質問


●質問をもっと探す●



0.人力検索はてなトップ
8.このページを友達に紹介
9.このページの先頭へ
対応機種一覧
お問い合わせ
ヘルプ/お知らせ
ログイン
無料ユーザー登録
はてなトップ