人力検索はてな
モバイル版を表示しています。PC版はこちら
i-mobile

mod_layoutについて
centos4.5でmod_layout4.1を無事インストールしましたが、
AddOutputFilter LAYOUT html
LayoutHeader /home/info/public_html/header.html
を全ページにheader.htmlを出力させようとしましたが,
真っ白な画面画表示されるだけです。
Makefileのパスが違っているのではないかと思いますが、

# the used tools
APXS=/usr/sbin/apxs
APACHECTL=/usr/sbin/apachectl

解決方法がお解かりの方がおられましたらお願いします。


●質問者: cherry-g
●カテゴリ:インターネット ウェブ制作
✍キーワード:HOME HTML Makefile mod_layout N/A
○ 状態 :終了
└ 回答数 : 5/5件

▽最新の回答へ

[1]apacheのインストール方法はどうしてますか? keino

apacheのバージョンやインストール先が不明なので何が悪いのか良く判りませんが、以下の所が参考になるのではないかと思います。

http://yaguma.com/Server/mod_layout.html

mod_layoutのパッケージには、必要とするapacheのバージョン要件があるみたいですが、上手くインストールできたということは、ここは満たしているのでしょうか?


[2]>1 回答ありがとうございます cherry-g

リンク先のサイトは参考にしました。

CentOs4.5 apache2.052

mod_layout4.1のインストール先:/usr/local/src

mod_layout4.01aでは、うまく動作したのですが、OSの再インストールを行い

mod_layout4.01aが見当たらなかったので、mod_layout4.1をインストールしました。

インストールは問題なく完了しましたが、mod_layoutで画像表示させようとするとhtmlでも真っ白な画面になります。ソースをみると、ヘッダー部分は正常にshift_jisで出力していますが、<body></body>となっており、

ボディーの部分がひろえていないようです。ご教授ください。

宜しくお願いします。


[3]>2 Versionの依存関係に問題があるかも keino

yumでインストールされたのが以下のURLに該当するものかどうかわかりませんが、apacheのバージョンが少し低いみたいです。

http://sea-mew.jp/nox/modules/rpms/el4/apache-mod_layout-4.0.1a-...

apacheのバージョンを2.0.58まで上げてみるか、mod_layoutをソースからコンパイルしてみるとよさそうです。mod_layoutのソースは、

http://tangent.org/374/Apache_2%2E0.html

からダウンロードできるようです。


[4]>3 回答ありがとうございます。 cherry-g

mod_layout4.0.1aのrpmがあるとは知りませんでした。

上記からrpmをダウンロードし

#rpm -Uvh apache-mod_layout-4.0.1a-4.1.100mdk.i386.rpm

実行したところ

エラー: Failed dependencies:

httpd-conf >= 2.0.54 is needed by apache-mod_layout-4.0.1a-4.1.100mdk.i386

libc.so.6()(64bit) is needed by apache-mod_layout-4.0.1a-4.1.100mdk.i386

libc.so.6(GLIBC_2.2.5)(64bit) is needed by apache-mod_layout-4.0.1a-4.1.100mdk.i386

rpm-helper is needed by apache-mod_layout-4.0.1a-4.1.100mdk.i386

エラーがでました。ここでエラーが出るということは

#rpm -ivh apache-mod_layout-4.0.1a-4.1.100mdk.i386.rpm

これを実行するとhttpdが破壊されるようなことはないのでしょうか。

また、ソースからインストールし,mod_layout4.1を実行しても状態は変わらずでした。

ご指摘のとおりapacheのバージョンが低いような感じがします。ただ自身で

ゲームサイトを運営しており、コントロールパネルをインストールしており、

apacheのバージョンを変更するときはOSの再インストールをせねばならず、

このままの状態でmod_layoutが利用できればいいと思っております。

宜しくお願いします。


[5]>4 この方法はどうでしょう。 keino

ご紹介したURLには、4.0.1a のソースもあったはずですが、そちらはコンパイルできませんか?

Apacheには2.0.58より前のバージョンには

セキュリティ上の問題があるので、こちらをアップグレードした方がいいんですけどね。

http://www.apache.jp/

関連質問


●質問をもっと探す●



0.人力検索はてなトップ
8.このページを友達に紹介
9.このページの先頭へ
対応機種一覧
お問い合わせ
ヘルプ/お知らせ
ログイン
無料ユーザー登録
はてなトップ