人力検索はてな
モバイル版を表示しています。PC版はこちら
i-mobile

apache2.0.59で
php5.2.3をインストールしているのですが
以下のようなエラーが表示されます。
Installing PHP SAPI module: apache2handler
/usr/local/apache2/build/instdso.sh SH_LIBTOOL='/usr/local/apache2/build/libtool' libphp5.la /usr/local/apache2/modules
/usr/local/apache2/build/libtool --mode=install cp libphp5.la /usr/local/apache2/modules/
cp .libs/libphp5.lai /usr/local/apache2/modules/libphp5.la
cp .libs/libphp5.a /usr/local/apache2/modules/libphp5.a
ranlib /usr/local/apache2/modules/libphp5.a
chmod 644 /usr/local/apache2/modules/libphp5.a
libtool: install: warning: remember to run `libtool --finish /src/php-5.2.3/libs'
Warning! dlname not found in /usr/local/apache2/modules/libphp5.la.
Assuming installing a .so rather than a libtool archive.
chmod 755 /usr/local/apache2/modules/libphp5.so
chmod: cannot access `/usr/local/apache2/modules/libphp5.so': そのようなファイルやディレクトリはありません
apxs:Error: Command failed with rc=65536
.
make: *** [install-sapi] エラー 1

作成されるファイルは以下になり、
libphp5.la、httpd.exp、libphp5.aで
libphp5.soが作成されないのですが、
どうしたらいいんでしょうか?
make distcleanをして再度インストールしても
結果は同じになってしまいます。





●質問者: hopefully
●カテゴリ:コンピュータ ウェブ制作
✍キーワード:2.0 access Command CP httpd
○ 状態 :終了
└ 回答数 : 2/2件

▽最新の回答へ

1 ● thrillseeker
●35ポイント

64bit 環境でこの問題が起きる事があるようです。

以下、手動でこれを回避する例:

http://www.sssg.org/blogs/hiro345/archives/2278.html

◎質問者からの返答

64bit 環境ってCentOS5なのですが、

それがいけないのでしょうか?

それともPHP5.2.3のソースがいけない?


2 ● hamster078
●35ポイント

apacheの場所などをインストールのオプションとして指定してやらなければならないのでしょうが、できればapacheのソースを用意して、phpを再コンパイル後にインストールが基本です。環境がちがうと、バイナリではインストールできません。

◎質問者からの返答

以下のコンフィグではだめなのでしょうか?

./configure \

関連質問


●質問をもっと探す●



0.人力検索はてなトップ
8.このページを友達に紹介
9.このページの先頭へ
対応機種一覧
お問い合わせ
ヘルプ/お知らせ
ログイン
無料ユーザー登録
はてなトップ