人力検索はてな
モバイル版を表示しています。PC版はこちら
i-mobile

OS X Server 10.3.9 Perl5.8.1 DBD::mysql2.9 インストール

インストールできません。どなたか助けてください。makeしたログは下記の通りです。そこで止まります。
(OS標準のMySQL4です。DBIは1.4です)

ld: /usr/lib/mysql/libmysqlclient.a(libmysql.o) stray relocation PPC_RELOC_PAIR entry (795) in section (__TEXT,__text)
make: *** [blib/arch/auto/DBD/mysql/mysql.bundle] Error 1


●質問者: Rabbit07
●カテゴリ:コンピュータ インターネット
✍キーワード:DBI LD LIB make Make:
○ 状態 :終了
└ 回答数 : 3/3件

▽最新の回答へ

1 ● makiton
●55ポイント

http://www.nabble.com/compatible-with-10.3--td3653640.html

Pantherは手元に無いので検証できないのですが、どうやらリンカ(ld)の互換性の問題のようですね。

ld自体を修正する方法を探してみましたが、見つかりませんでした。

上のURLも、結論としては「無理」ということになっているようです。


日本語の記事でMakefileを修正する方法を見つけました。

makeしたディレクトリ内にMakefileがあるはずなので、以下の修正を入れてみてください。

http://clouder.jp/yoshiki/mt/archives/000137.html

◎質問者からの返答

ご回答ありがとう、ございます。

この手順は既に、対処したつもりでいます。


2 ● ffmpeg
●20ポイント

すいいません。前記はmysql本体とまちがえてました。

perlモジュールについて関係ありそうな記事

http://d.hatena.ne.jp/smotokezuru/20080127/1201424655

◎質問者からの返答

ご回答ありがとう、ございます。

しかし、当環境はリモートではなく、ローカルなんですね。


3 ● ffmpeg
●5ポイント

mac os x 10.3.9(serverではない)で私がmysql-5.0.27をコンパイルしたときは、

これで通ってますね。

./configure --prefix=/usr/local/mysql --mandir=/usr/local/share/man --infodi

r=/usr/local/share/info --with-charset=binary --with-extra-charsets=complex --wi

thout-libedit --with-readline

関連質問


●質問をもっと探す●



0.人力検索はてなトップ
8.このページを友達に紹介
9.このページの先頭へ
対応機種一覧
お問い合わせ
ヘルプ/お知らせ
ログイン
無料ユーザー登録
はてなトップ