人力検索はてな
モバイル版を表示しています。PC版はこちら
i-mobile

サイトを丸ごとSSLの効いているディレクトリに入れているのですが
なぜか「保護されていない項目が含まれています」というエラーが出てしまいます。

エラーが出るのは windows XP + IE 6.0 です。

windows VIST + IE 7 や Mac は出ません。

お心当たりがありましたら教えてください。
お願いします。

●質問者: worldtravel
●カテゴリ:コンピュータ ウェブ制作
✍キーワード:IE MAC SSL Windows Windows XP
○ 状態 :終了
└ 回答数 : 3/3件

▽最新の回答へ

1 ● pahoo
●10ポイント

コンテンツの中に、画像やFlashなど、http://?ではじまるものが含まれていませんか?

さらにIE6とIE7のセキュリティ・レベル設定が違う場合、「保護されていない項目が含まれています」が表示されるかどうか変わってきます。

http://kikky.net/pc/ssl_err2.html

http://pasofaq.jp/program/internetexplorer/security.htm

◎質問者からの返答

画像やFlashなどは全てSSLの奇異いているディレクトリ内へのパスにしています。

ですが、この警告が出てしまいます。

まさか画像等は全て「https://...」と書かなければいけないと言う事は無いですよね?

「./ccc.jpg」「../xxx/xxxjpg」などとしていますが...


2 ● znz
●10ポイント

Google Analytics のようなものをhttpで始まるURLで埋め込んでいると言うことはないでしょうか?

◎質問者からの返答

ありがとうございます。

問題のページは管理者用のページなのでアクセス解析関連は入れていません。


3 ● gday
●60ポイント ベストアンサー

http://blog.weekendphp.com/2007/11/08/ie6ssl.html

IE7やFireFoxなどではまったくセキュアな通信だと言われるのに、なぜ!!!!と、途方に暮れてしまった。

(略)

それによると、IE6で、srcなしで空のiframeがあると、セキュリティの警告がでる、といったもの。

これに引っかかっているのでは?

◎質問者からの返答

おおおおお!!!

これでした。

ありがとうございます。

wysiwygを使っており、「src=""」にしていました。

教えていただいたURLの通り空のファイルを作り、指定したら警告は表示されなくなりました。

関連質問


●質問をもっと探す●



0.人力検索はてなトップ
8.このページを友達に紹介
9.このページの先頭へ
対応機種一覧
お問い合わせ
ヘルプ/お知らせ
ログイン
無料ユーザー登録
はてなトップ