人力検索はてな
モバイル版を表示しています。PC版はこちら
i-mobile

PHPでの「Segmentation fault」について教えて下さい。

下記のPHPを実行した結果、上記のエラーが表示されます。
<?php
$aaa->xxx = 'a';
?>

PHPのバージョンは下記の通りです。
PHP 5.2.6 (cgi) (built: May 8 2008 13:19:29)
Copyright (c) 1997-2008 The PHP Group
Zend Engine v2.2.0, Copyright (c) 1998-2008 Zend Technologies

動作させているサーバーは下記となります。
FreeBSD 6.1-RELEASE-p23

これは、某レンタルサーバーにて、PHPで作成していた環境が急に動かなくなり、
原因を探っていた結果、上記命令において、stdClassが自動で割り当てられずに
「Segmentation fault」になる所まで特定を致しました。

しかしながら、サポートセンターの方の知識が無く、上記の現象について説明させて
頂きましたが、こちらのPHPのファイルの内容の問題だろうと言われてしまっております。

レンタルサーバー業者に、お宅の環境が悪いのだと、
明確に指摘する材料をご教示頂けないでしょうか。


●質問者: Phynel
●カテゴリ:コンピュータ ウェブ制作
✍キーワード:2.0 AAA CGI copyright E-P2
○ 状態 :終了
└ 回答数 : 1/1件

▽最新の回答へ

1 ● pyopyopyo
●60ポイント

技術的な話はせずに

今まで何の問題もなく動作していた,

$aaa->xxx = 'a';

?>

がx月x日から突然動作しなくなった

事前の連絡もなく,勝手にサーバの設定を替えてもらっては困る

サーバの設定を元に戻すか,不具合の原因と対処方法を調査して至急回答ください

と伝えるだけでは駄目でしょうか?

それでも回答が得られない場合は,契約内容にも関わるので,もっと上の人に苦情を出しましょう.

ポイントは「勝手に設定を替えてもらっては困る」です.

なお上記のコードは,私の手元のphp5.2.6(os:debian/unstable)では問題なく動作します

◎質問者からの返答

コメントありがとうございます。

伝えた結果、PHPの内容については、サポート対象外だと言われまして、

いかにPHPの内容が関係ないのだという事を証明する事が出来ると楽なのかなと思っております。

とりあえず設定変更しては困るの言葉は使わせて頂きます。

関連質問


●質問をもっと探す●



0.人力検索はてなトップ
8.このページを友達に紹介
9.このページの先頭へ
対応機種一覧
お問い合わせ
ヘルプ/お知らせ
ログイン
無料ユーザー登録
はてなトップ